summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-terms/mrxvt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-terms/mrxvt')
-rw-r--r--x11-terms/mrxvt/Manifest1
-rw-r--r--x11-terms/mrxvt/files/mrxvt-0.5.4-001-fix-segfault-when-wd-empty.patch13
-rw-r--r--x11-terms/mrxvt/files/mrxvt-0.5.4-libpng14.patch33
-rw-r--r--x11-terms/mrxvt/metadata.xml16
-rw-r--r--x11-terms/mrxvt/mrxvt-0.5.4.ebuild119
5 files changed, 182 insertions, 0 deletions
diff --git a/x11-terms/mrxvt/Manifest b/x11-terms/mrxvt/Manifest
new file mode 100644
index 000000000000..28e88e2c5929
--- /dev/null
+++ b/x11-terms/mrxvt/Manifest
@@ -0,0 +1 @@
+DIST mrxvt-0.5.4.tar.gz 603978 SHA256 f403ad5a908fcd38a55ed0a7e1b85584cb77be8781199653a39b8af1a9ad10d7 SHA512 572bb4dda9f9b9dcb597f3185922646523bce34003f536acca82992f68f8f7c1a5f2778d626f805ea2cd061e8451fbbf12010e5d655221f76b83440825c80992 WHIRLPOOL 770acc0b03e13e113bfe01f56e9ec58ddba6ae2ee989236836f4dd557dfa89334af8404e3fb5a08e1ffea989852f89871004eb6bd46a2d0b2b9830aaf1dc0455
diff --git a/x11-terms/mrxvt/files/mrxvt-0.5.4-001-fix-segfault-when-wd-empty.patch b/x11-terms/mrxvt/files/mrxvt-0.5.4-001-fix-segfault-when-wd-empty.patch
new file mode 100644
index 000000000000..a52a10269bc1
--- /dev/null
+++ b/x11-terms/mrxvt/files/mrxvt-0.5.4-001-fix-segfault-when-wd-empty.patch
@@ -0,0 +1,13 @@
+Index: src/tabbar.c
+===================================================================
+--- src/tabbar.c (revision 337)
++++ src/tabbar.c (working copy)
+@@ -1327,7 +1327,7 @@
+ if( p.we_wordc > 1)
+ rxvt_msg( DBG_ERROR, DBG_TABBAR,
+ "Too many words when expanding %s\n", cwdOption );
+- else
++ else if( NOT_NULL( *p.we_wordv ) )
+ {
+ filename = *p.we_wordv;
+
diff --git a/x11-terms/mrxvt/files/mrxvt-0.5.4-libpng14.patch b/x11-terms/mrxvt/files/mrxvt-0.5.4-libpng14.patch
new file mode 100644
index 000000000000..a475b70685dc
--- /dev/null
+++ b/x11-terms/mrxvt/files/mrxvt-0.5.4-libpng14.patch
@@ -0,0 +1,33 @@
+http://repos.archlinux.org/wsvn/packages/mrxvt/trunk/libpng14.patch
+
+--- configure.ac
++++ configure.ac
+@@ -952,7 +952,7 @@
+ if test "x$support_png" = "xyes"; then
+ AC_CHECK_LIB(
+ png,
+- png_check_sig,
++ png_sig_cmp,
+ [],
+ [support_png=no],
+ [-lz -lm]
+--- src/mpng.c
++++ src/mpng.c
+@@ -83,7 +83,7 @@
+ display_depth = XDefaultDepth(display,XDefaultScreen(display));
+
+ fread(sig, 1, 8, ifile);
+- if (!png_check_sig(sig, 8)){
++ if (png_sig_cmp(sig, 0, 8)){
+ fclose(ifile);
+ return -1;
+ }
+@@ -113,7 +113,7 @@
+
+ if (png_depth < 8){
+ if (png_color_type == PNG_COLOR_TYPE_GRAY ){
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ png_row_bytes = png_width;
+ }else{
+ png_set_expand(png_ptr);
diff --git a/x11-terms/mrxvt/metadata.xml b/x11-terms/mrxvt/metadata.xml
new file mode 100644
index 000000000000..295329dc87ff
--- /dev/null
+++ b/x11-terms/mrxvt/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <use>
+ <flag name="menubar">Enable mrxvt menubar</flag>
+ <flag name="utempter">REcords user logins. Useful on multi-user
+ systems</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">materm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-terms/mrxvt/mrxvt-0.5.4.ebuild b/x11-terms/mrxvt/mrxvt-0.5.4.ebuild
new file mode 100644
index 000000000000..f40c0ffbad3b
--- /dev/null
+++ b/x11-terms/mrxvt/mrxvt-0.5.4.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="Multi-tabbed rxvt clone with XFT, transparent background and CJK support"
+HOMEPAGE="http://materm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/materm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~mips ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+LINGUAS_IUSE="linguas_el linguas_ja linguas_ko linguas_th linguas_zh_CN linguas_zh_TW"
+IUSE="debug png jpeg session truetype menubar utempter xpm ${LINGUAS_IUSE}"
+
+RDEPEND="png? ( media-libs/libpng )
+ utempter? ( sys-libs/libutempter )
+ jpeg? ( virtual/jpeg )
+ truetype? ( x11-libs/libXft
+ media-libs/fontconfig
+ media-libs/freetype
+ elibc_uclibc? ( dev-libs/libiconv ) )
+ x11-libs/libX11
+ x11-libs/libXt
+ xpm? ( x11-libs/libXpm )
+ x11-libs/libXrender"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-001-fix-segfault-when-wd-empty.patch \
+ "${FILESDIR}"/${P}-libpng14.patch
+
+ eautoreconf
+
+ if use elibc_uclibc && use truetype; then
+ # It is stated in the README "Multichar support under XFT requires GNU iconv"
+ sed -i -e 's/LIBS = @LIBS@/LIBS = @LIBS@ -liconv/' "${S}/src/Makefile.in"
+ fi
+}
+
+src_configure() {
+ local myconf
+
+ # if you want to pass any other flags, use EXTRA_ECONF.
+ if use linguas_el ; then
+ myconf="${myconf} --enable-greek"
+ fi
+ if use linguas_ja ; then
+ # --with-encoding=sjis
+ myconf="${myconf} --enable-kanji --with-encoding=eucj"
+ fi
+ if use linguas_ko ; then
+ myconf="${myconf} --enable-kr --with-encoding=kr"
+ fi
+ if use linguas_th ; then
+ myconf="${myconf} --enable-thai"
+ fi
+ if use linguas_zh_CN ; then
+ # --with-encoding=gbk
+ myconf="${myconf} --enable-gb --with-encoding=gb"
+ fi
+ if use linguas_zh_TW ; then
+ myconf="${myconf} --enable-big5 --with-encoding=big5"
+ fi
+
+ # 2006-03-13 gi1242: mrxvt works best with TERM=rxvt AND correctly set
+ # termcap / terminfo entries. If the rxvt termcap / terminfo entries are
+ # messed up then then it's better to set TERM=xterm.
+ #
+ # Provide support for this by setting the or RXVT_TERM environment variables
+ # before emerging, as done in the rxvt ebuild.
+
+ if [[ -n ${RXVT_TERM} ]]; then
+ myconf="${myconf} --with-term=${RXVT_TERM}"
+ fi
+
+ econf \
+ --enable-everything \
+ --with-atab-extra=25 \
+ $(use_enable debug) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable xpm) \
+ $(use_enable session sessionmgr) \
+ $(use_enable truetype xft) \
+ $(use_enable utempter) \
+ $(use_enable menubar) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="${EPREFIX}"/usr/share/doc/${PF} install
+ # Give mrxvt perms to update utmp
+ fowners root:utmp /usr/bin/mrxvt
+ fperms g+s /usr/bin/mrxvt
+ dodoc AUTHORS CREDITS ChangeLog FAQ NEWS README* TODO
+}
+
+pkg_postinst() {
+ if [[ -z $RXVT_TERM ]]; then
+ einfo
+ einfo "If you experience problems with curses programs, then this is"
+ einfo "most likely because of incorrectly set termcap / terminfo"
+ einfo "entries. To fix this you can dry and run (as user)"
+ einfo " tic /usr/share/doc/${P}/etc/mrxvt.terminfo"
+ einfo "Alternately, run the offending programs with TERM=xterm."
+ einfo
+ einfo "To emerge mrxvt with TERM=xterm by default, set the RXVT_TERM"
+ einfo "environment variable to 'xterm', or your desired default"
+ einfo "terminal name. Alternately you can put 'Mrxvt.termName: xterm'"
+ einfo "in your ~/.mrxvtrc, or /etc/mrxvt/mrxvtrc."
+ einfo
+ fi
+}