summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-themes/fvwm-crystal
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-themes/fvwm-crystal')
-rw-r--r--x11-themes/fvwm-crystal/Manifest2
-rw-r--r--x11-themes/fvwm-crystal/fvwm-crystal-3.2.3.ebuild58
-rw-r--r--x11-themes/fvwm-crystal/fvwm-crystal-3.2.5.ebuild58
-rw-r--r--x11-themes/fvwm-crystal/metadata.xml24
4 files changed, 142 insertions, 0 deletions
diff --git a/x11-themes/fvwm-crystal/Manifest b/x11-themes/fvwm-crystal/Manifest
new file mode 100644
index 000000000000..345b13617c67
--- /dev/null
+++ b/x11-themes/fvwm-crystal/Manifest
@@ -0,0 +1,2 @@
+DIST fvwm-crystal-3.2.3.tar.gz 4388604 SHA256 f259fb40506b3bc5dd061f007d15a621f39c5c5bae7f320951f459ff43abb8cc SHA512 fa3d17b55562f773a50e00954aa66d22ce59fd62153ddf84a3df2ace1bc480abc2311bf379e2593f234330033f83ef3800378bfe3da593cdeb8b80b284d299bf WHIRLPOOL 85cec67e583fa2d9feb40d601f66f8beeb41141b3f0f3b9ca15b9f8dda0f7aa8277ce78a7908d8527e28ee8fc03e5df2420681db8a06220a00add74dc671739b
+DIST fvwm-crystal-3.2.5.tar.gz 4474561 SHA256 ecb21f419e3bfb27f1c0bd15c6a298f57f125d6b857e45c129f1988a3c0a244a SHA512 f3b494da1f0851d0e16dda8a8867314a1b089d5a6c9ab18eedea6cdfaa753dff26f0e49747b12ec251812a22dcd93f348d6f3b689c9289b95e28545a245fadb1 WHIRLPOOL ee44b0a56e09b4fd99981de704d3170f07fa567d19cc5da874c174ffe54e1b44a9187d4e6cac78301e9d1c20c5c30d419a0f03016d80a8c26469058efa1e5f11
diff --git a/x11-themes/fvwm-crystal/fvwm-crystal-3.2.3.ebuild b/x11-themes/fvwm-crystal/fvwm-crystal-3.2.3.ebuild
new file mode 100644
index 000000000000..e65342e28c80
--- /dev/null
+++ b/x11-themes/fvwm-crystal/fvwm-crystal-3.2.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-r1
+
+DESCRIPTION="Configurable and full featured FVWM theme, with lots of transparency and freedesktop compatible menu"
+HOMEPAGE="http://fvwm-crystal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+
+RDEPEND="${PYTHON_DEPS}
+ >=x11-wm/fvwm-2.6.5[png]
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ || ( >=x11-misc/stalonetray-0.6.2-r2 x11-misc/trayer )
+ || ( x11-misc/hsetroot media-gfx/feh )
+ sys-apps/sed
+ sys-devel/bc
+ virtual/awk
+ x11-apps/xwd"
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ docdir="/usr/share/doc/${PF}" \
+ prefix="/usr" \
+ install
+
+ python_replicate_script \
+ "${D}/usr/bin/${PN}".{apps,wallpaper} \
+ "${D}/usr/share/${PN}"/fvwm/scripts/FvwmMPD/*.py
+}
+
+pkg_postinst() {
+ einfo
+ einfo "After installation, execute following commands:"
+ einfo " $ cp -r ${ROOT}usr/share/doc/${PF}/addons/Xresources ~/.Xresources"
+ einfo " $ cp -r ${ROOT}usr/share/doc/${PF}/addons/Xsession ~/.xinitrc"
+ einfo
+ einfo "Many applications can extend functionality of fvwm-crystal."
+ einfo "They are listed in ${ROOT}usr/share/doc/${PF}/INSTALL.gz."
+ einfo
+ einfo "Some icons fixes was committed recently."
+ einfo "To archive the same fixes on your private icon files,"
+ einfo "please read ${ROOT}usr/share/doc/${PF}/INSTALL.gz."
+ einfo "This will fix the libpng warnings at stderr."
+ einfo
+ einfo "The color themes was updated to Fvwm InfoStore."
+ einfo "To know how to update your custom color themes, please run"
+ einfo " ${ROOT}usr/share/${PN}/addons/convert_colorsets"
+ einfo ""
+}
diff --git a/x11-themes/fvwm-crystal/fvwm-crystal-3.2.5.ebuild b/x11-themes/fvwm-crystal/fvwm-crystal-3.2.5.ebuild
new file mode 100644
index 000000000000..f76c9fc3ee28
--- /dev/null
+++ b/x11-themes/fvwm-crystal/fvwm-crystal-3.2.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-r1
+
+DESCRIPTION="Configurable and full featured FVWM theme, with lots of transparency and freedesktop compatible menu"
+HOMEPAGE="http://fvwm-crystal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="${PYTHON_DEPS}
+ >=x11-wm/fvwm-2.6.5[png]
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ || ( >=x11-misc/stalonetray-0.6.2-r2 x11-misc/trayer )
+ || ( x11-misc/hsetroot media-gfx/feh )
+ sys-apps/sed
+ sys-devel/bc
+ virtual/awk
+ x11-apps/xwd"
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ docdir="/usr/share/doc/${PF}" \
+ prefix="/usr" \
+ install
+
+ python_replicate_script \
+ "${D}/usr/bin/${PN}".{apps,wallpaper} \
+ "${D}/usr/share/${PN}"/fvwm/scripts/FvwmMPD/*.py
+}
+
+pkg_postinst() {
+ einfo
+ einfo "After installation, execute following commands:"
+ einfo " $ cp -r ${ROOT}usr/share/doc/${PF}/addons/Xresources ~/.Xresources"
+ einfo " $ cp -r ${ROOT}usr/share/doc/${PF}/addons/Xsession ~/.xinitrc"
+ einfo
+ einfo "Many applications can extend functionality of fvwm-crystal."
+ einfo "They are listed in ${ROOT}usr/share/doc/${PF}/INSTALL.gz."
+ einfo
+ einfo "Some icons fixes was committed recently."
+ einfo "To archive the same fixes on your private icon files,"
+ einfo "please read ${ROOT}usr/share/doc/${PF}/INSTALL.gz."
+ einfo "This will fix the libpng warnings at stderr."
+ einfo
+ einfo "The color themes was updated to Fvwm InfoStore."
+ einfo "To know how to update your custom color themes, please run"
+ einfo " ${ROOT}usr/share/${PN}/addons/convert_colorsets"
+ einfo ""
+}
diff --git a/x11-themes/fvwm-crystal/metadata.xml b/x11-themes/fvwm-crystal/metadata.xml
new file mode 100644
index 000000000000..729da74629f0
--- /dev/null
+++ b/x11-themes/fvwm-crystal/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>dominique.michel@vtxnet.ch</email>
+ <name>Dominique Michel</name>
+ </maintainer>
+ <longdescription>
+FVWM-Crystal is a set of configuration files for FVWM window manager,
+with additional programs and scripts. Some of it's features are:
+ * quick launching of a terminal with just one click on a desktop
+ * a specially configured terminal window, similar to a console from FPP games
+ * builtin control over XMMS player and over aumix mixer from the keyboard and
+ buttons on the screen
+ * very good ability to control the desktop from the keyboard, including window
+ switching, moving, shading/unshading, maximizing, resizing, moving between
+ desktop pages
+ * transparent window titlebars, menus and panels on the desktop
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">fvwm-crystal</remote-id>
+ </upstream>
+</pkgmetadata>