summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-02-19 21:19:33 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-02-19 21:19:39 +1100
commit4ebf3ecc97f643297bf34f02cf4ad51121e46e81 (patch)
treeb0fbb56ba9031ecd2aad7fe48f088d2399fd85d7 /x11-themes/smplayer-themes/smplayer-themes-15.12.0.ebuild
parentmedia-sound/karlyriceditor: remove old (diff)
downloadgentoo-4ebf3ecc97f643297bf34f02cf4ad51121e46e81.tar.gz
gentoo-4ebf3ecc97f643297bf34f02cf4ad51121e46e81.tar.bz2
gentoo-4ebf3ecc97f643297bf34f02cf4ad51121e46e81.zip
x11-themes/smplayer-themes: version bump
Gentoo-bug: 572846 Package-Manager: portage-2.2.27
Diffstat (limited to 'x11-themes/smplayer-themes/smplayer-themes-15.12.0.ebuild')
-rw-r--r--x11-themes/smplayer-themes/smplayer-themes-15.12.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-themes/smplayer-themes/smplayer-themes-15.12.0.ebuild b/x11-themes/smplayer-themes/smplayer-themes-15.12.0.ebuild
new file mode 100644
index 000000000000..19849b879b78
--- /dev/null
+++ b/x11-themes/smplayer-themes/smplayer-themes-15.12.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="Icon themes for smplayer"
+HOMEPAGE="http://smplayer.sourceforge.net/"
+SRC_URI="mirror://sourceforge/smplayer/${P}.tar.bz2"
+
+LICENSE="CC-BY-2.5 CC-BY-SA-2.5 CC-BY-SA-3.0 GPL-2 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:4"
+RDEPEND="media-video/smplayer"
+
+src_prepare() {
+ default
+
+ # bug 544108
+ sed -i -e "s| rcc| \"$(qt4_get_bindir)\"/rcc|" themes/Makefile || die
+
+ # bug 544160
+ sed -i -e 's/make/$(MAKE)/' Makefile || die
+}
+
+src_install() {
+ rm themes/Makefile themes/H2O/Makefile || die
+ insinto /usr/share/smplayer
+ doins -r themes
+ dodoc Changelog README.txt
+}