summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2022-03-21 18:37:05 +0700
committerAndrey Grozin <grozin@gentoo.org>2022-03-21 18:37:05 +0700
commit1c80598421d13eba4993898b1f6c7afcd2ae7d2b (patch)
treebfb6ac76c2e9294e864bb99ad1850dab9609b412 /x11-wm/lumina
parentdev-qt/qtwayland: Cleanup duplicate patch file (diff)
downloadgentoo-1c80598421d13eba4993898b1f6c7afcd2ae7d2b.tar.gz
gentoo-1c80598421d13eba4993898b1f6c7afcd2ae7d2b.tar.bz2
gentoo-1c80598421d13eba4993898b1f6c7afcd2ae7d2b.zip
x11-wm/lumina: bump to 1.6.2
Closes: https://bugs.gentoo.org/835643 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'x11-wm/lumina')
-rw-r--r--x11-wm/lumina/Manifest1
-rw-r--r--x11-wm/lumina/lumina-1.6.2.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/x11-wm/lumina/Manifest b/x11-wm/lumina/Manifest
index 1f5a99c7b878..d7fc9602f339 100644
--- a/x11-wm/lumina/Manifest
+++ b/x11-wm/lumina/Manifest
@@ -1,2 +1,3 @@
DIST lumina-1.6.0.tar.gz 20662000 BLAKE2B c016f07fb86333e792d6a0a0ddaa9ea09f322d6de69d099abf9340d7db6cb9e23624b62882579ba6c13eec71fcf663f1688424fd940cd7e09e625f6fcc4b281f SHA512 e923961568ab9cc32206386066daef8cd1fd2db2d5c3e260e5c1da1dcda39a516576418f607cefbe5a1c47d8684591d0e595fb344e7d6aa2859fc3b326e73e30
DIST lumina-1.6.1.tar.gz 20614263 BLAKE2B c0ad6a48d06ec9b2c0856a673319cb6a022416465e5f15fce47aac62d7e1817dc8b01acc7c55eaf3664217f2f27ef1b4d7a603a355cd9e22b707b481b322783a SHA512 ff4a77812e8d91478cbfd123ddc545e5a4aaabf3d9f96e6dedc769eb9490e4ac372c4243dca9444cdf986886c08e2eaa587470c9bc8a5a00bbe10ff80ad64c96
+DIST lumina-1.6.2.tar.gz 20818383 BLAKE2B ecb2d4c1f3ce94f247cd86640bd6394807ed5d9a34b2256d333894e6528c0d3dac1ddcab8c790a63df67c2738ab7af8dd2ef0cae67c534e10c4b2edd8919ad8c SHA512 0bebdc89644af49232ad9a0b753dee501f3e99d6615ce926c71790932d228e3c6676ca4835aeaf6badf5455102278261e48bed0d3004fe9209aca68d620cae02
diff --git a/x11-wm/lumina/lumina-1.6.2.ebuild b/x11-wm/lumina/lumina-1.6.2.ebuild
new file mode 100644
index 000000000000..c49afaa5aa0c
--- /dev/null
+++ b/x11-wm/lumina/lumina-1.6.2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PLOCALES="af ar az bg bn bs ca cs cy da de el en_AU en_GB en_ZA es et eu fa fi fr fr_CA fur gl he hi hr hu id is it ja ka ko lt lv mk mn ms mt nb ne nl pa pl pt pt_BR ro ru sa sk sl sr sv sw ta tg th tr uk ur uz vi zh_CN zh_HK zh_TW zu"
+inherit plocale qmake-utils xdg
+
+DESCRIPTION="Lumina desktop environment"
+HOMEPAGE="https://lumina-desktop.org/"
+SRC_URI="https://github.com/trueos/${PN}/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="desktop-utils"
+
+DEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5[widgets]
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libxcb:0
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm
+ desktop-utils? ( app-text/poppler[qt5] )"
+
+RDEPEND="${DEPEND}
+ app-admin/sysstat
+ media-sound/alsa-utils
+ sys-fs/inotify-tools
+ sys-power/acpi
+ || (
+ x11-apps/xbacklight
+ sys-power/acpilight
+ )
+ x11-misc/numlockx
+ x11-wm/fluxbox"
+
+BDEPEND="
+ dev-qt/linguist-tools:5"
+
+S="${WORKDIR}/${P/_/-}"
+
+PATCHES=(
+ "${FILESDIR}/1.6.1-desktop-files.patch"
+)
+
+DOCS=( README.md )
+
+src_prepare() {
+ default
+
+ if ! use desktop-utils ; then
+ rm -rf src-qt5/desktop-utils || die
+ sed -e "/desktop-utils/d" -i src-qt5/src-qt5.pro || die
+ fi
+
+ plocale_find_changes "${S}/src-qt5/core/${PN}-desktop/i18n" "${PN}-desktop_" '.ts'
+}
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr" LIBPREFIX="${EPREFIX}/usr/$(get_libdir)" \
+ CONFIG+=WITH_I18N QMAKE_CFLAGS_ISYSTEM=
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+ einstalldocs
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}/lumina-session" lumina ||die
+
+ remove_locale() {
+ rm -f "${ED}"/usr/share/${PN}-desktop/i18n/l*_${1}.qm
+
+ }
+ plocale_for_each_disabled_locale remove_locale
+}