summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/notion
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/notion')
-rw-r--r--x11-wm/notion/Manifest2
-rw-r--r--x11-wm/notion/files/notion2
-rw-r--r--x11-wm/notion/files/notion-3_p2015061300-pkg-config.patch76
-rw-r--r--x11-wm/notion/files/notion.desktop8
-rw-r--r--x11-wm/notion/metadata.xml12
-rw-r--r--x11-wm/notion/notion-3_p2013030200.ebuild84
-rw-r--r--x11-wm/notion/notion-3_p2015061300-r1.ebuild89
-rw-r--r--x11-wm/notion/notion-9999.ebuild87
8 files changed, 360 insertions, 0 deletions
diff --git a/x11-wm/notion/Manifest b/x11-wm/notion/Manifest
new file mode 100644
index 000000000000..de2c8c1e351d
--- /dev/null
+++ b/x11-wm/notion/Manifest
@@ -0,0 +1,2 @@
+DIST notion-3-2013030200-src.tar.bz2 625211 SHA256 565d85757cf5aac0193498339d245d3fd34dff09a1f2816735cae584a5b863e7 SHA512 266df9ca2f3613c7138a3bfe7bab1fadd27c1ad40078d134be827167b9407b900bc240780cb5375e6996777978bb8a3bc12fbfa45bb4d8d619ee93335c6039b2 WHIRLPOOL 23831d187dc23bffb83965015c0d052cb4a7378c6599dfac0d0fb845e624e7dd934be7a2a1e6bb8598330d9fbf621cc346986baeff3d96b16018774a116f7dd0
+DIST notion-3_p2015061300.tar.gz 797057 SHA256 3c9d9f35a9fb0d17c263b76fe28f7a1a4a05b7d6140545524cc1effd98c5c305 SHA512 254be12a8ece555d9f6253d99891bb51214379d0c04b6bf9595b7e5bf9493cb5d2fada37438f89621e7157f9e3647e446b5e173847498ee3608081f006b86679 WHIRLPOOL 15263dd3298e90f0f16119198b01e1466acba7cf431d2d6a56e71f53b35a2461be7155462b31d9da6c0a652e8fd33b7b9fbf6960a64f956e9853ad3030e8bcb8
diff --git a/x11-wm/notion/files/notion b/x11-wm/notion/files/notion
new file mode 100644
index 000000000000..65bf5648ad0b
--- /dev/null
+++ b/x11-wm/notion/files/notion
@@ -0,0 +1,2 @@
+#!/bin/sh
+/usr/bin/notion
diff --git a/x11-wm/notion/files/notion-3_p2015061300-pkg-config.patch b/x11-wm/notion/files/notion-3_p2015061300-pkg-config.patch
new file mode 100644
index 000000000000..fb718caa3158
--- /dev/null
+++ b/x11-wm/notion/files/notion-3_p2015061300-pkg-config.patch
@@ -0,0 +1,76 @@
+--- notion-3-2015061300/system-autodetect.mk
++++ notion-3-2015061300/system-autodetect.mk
+@@ -84,8 +84,8 @@
+ # SunOS/Solaris
+ #X11_PREFIX ?= /usr/openwin
+
+-X11_LIBS=-L$(X11_PREFIX)/lib -lX11 -lXext
+-X11_INCLUDES=-I$(X11_PREFIX)/include
++X11_LIBS=$(shell $(PKG_CONFIG) --libs x11 xext)
++X11_INCLUDES=$(shell $(PKG_CONFIG) --cflags-only-I x11 xext)
+
+ # XFree86 libraries up to 4.3.0 have a bug that can cause a segfault.
+ # The following setting should work around that situation.
+--- notion-3-2015061300/mod_xinerama/Makefile
++++ notion-3-2015061300/mod_xinerama/Makefile
+@@ -9,14 +9,14 @@
+
+ ######################################
+
+-INCLUDES += $(LIBTU_INCLUDES) $(LIBEXTL_INCLUDES) $(X11_INCLUDES) -I$(TOPDIR)
+-CFLAGS += $(XOPEN_SOURCE) $(C99_SOURCE)
++INCLUDES += $(LIBTU_INCLUDES) $(LIBEXTL_INCLUDES) $(X11_INCLUDES) -I$(TOPDIR) $(shell $(PKG_CONFIG) --cflags-only-I xinerama)
++CFLAGS += $(XOPEN_SOURCE) $(C99_SOURCE) $(shell $(PKG_CONFIG) --cflags-only-other xinerama)
+ DOCS=LICENSE README
+
+ SOURCES=mod_xinerama.c
+
+ MAKE_EXPORTS=mod_xinerama
+-LIBS = -L/usr/lib/x86_64-linux-gnu $(X11_LIBS) -lXinerama
++LIBS = $(X11_LIBS) $(shell $(PKG_CONFIG) --libs xinerama)
+ MODULE=mod_xinerama
+ MODULE_STUB=mod_xinerama.lua
+
+@@ -44,7 +44,7 @@
+
+ .PHONY: test
+ test: $(SOURCES)
+- lua test_xinerama.lua
++ $(LUA) test_xinerama.lua
+
+ ######################################
+
+@@ -57,4 +57,4 @@
+ ################ ls_xinerama utility ###############
+
+ ls_xinerama: ls_xinerama.c
+- $(CC) ls_xinerama.c -o ls_xinerama -Wl,--as-needed -lX11 -lXinerama
++ $(CC) $(CFLAGS) ls_xinerama.c -o ls_xinerama $(LDFLAGS) $(LIBS)
+--- notion-3-2015061300/mod_xrandr/Makefile
++++ notion-3-2015061300/mod_xrandr/Makefile
+@@ -9,13 +9,13 @@
+
+ ######################################
+
+-INCLUDES += $(LIBTU_INCLUDES) $(LIBEXTL_INCLUDES) $(X11_INCLUDES) -I$(TOPDIR)
+-CFLAGS += $(XOPEN_SOURCE) $(C99_SOURCE)
++INCLUDES += $(LIBTU_INCLUDES) $(LIBEXTL_INCLUDES) $(X11_INCLUDES) -I$(TOPDIR) $(shell pkg-config --cflags-only-I xrandr)
++CFLAGS += $(XOPEN_SOURCE) $(C99_SOURCE) $(shell $(PKG_CONFIG) --cflags-only-other xrandr)
+
+ SOURCES=mod_xrandr.c
+
+ MAKE_EXPORTS=mod_xrandr
+-LIBS = $(X11_LIBS) -lXrandr
++LIBS = $(X11_LIBS) $(shell $(PKG_CONFIG) --libs xrandr)
+ MODULE=mod_xrandr
+ MODULE_STUB=mod_xrandr.lua
+ ETC=cfg_xrandr.lua
+@@ -45,7 +45,7 @@
+
+ .PHONY: test
+ test: $(SOURCES)
+- for i in test_xrandr*.lua ; do echo 'Testing' $$i ; lua $$i ; done
++ for i in test_xrandr*.lua ; do echo 'Testing' $$i ; $(LUA) $$i ; done
+
+ ######################################
+
diff --git a/x11-wm/notion/files/notion.desktop b/x11-wm/notion/files/notion.desktop
new file mode 100644
index 000000000000..7c9de9a95fd3
--- /dev/null
+++ b/x11-wm/notion/files/notion.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Notion
+Comment=A tiling tabbed window manager designed with keyboard users in mind.
+Exec=notion
+TryExec=notion
+# no icon yet, only the top three are currently used
+Icon=
+Type=Application
diff --git a/x11-wm/notion/metadata.xml b/x11-wm/notion/metadata.xml
new file mode 100644
index 000000000000..e708492171df
--- /dev/null
+++ b/x11-wm/notion/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>moaxcp@gmail.com</email>
+ <name>John Mercier</name>
+ </maintainer>
+ <use>
+ <flag name="xrandr">Add support for xrandr</flag>
+ </use>
+</pkgmetadata>
diff --git a/x11-wm/notion/notion-3_p2013030200.ebuild b/x11-wm/notion/notion-3_p2013030200.ebuild
new file mode 100644
index 000000000000..335288e78075
--- /dev/null
+++ b/x11-wm/notion/notion-3_p2013030200.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Notion is a tiling, tabbed window manager for the X window system"
+HOMEPAGE="http://notion.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/files/${P/_p/-}-src.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls xinerama +xrandr"
+
+RDEPEND=">=dev-lang/lua-5.1:0=
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-libs/libXinerama )
+ xrandr? ( x11-libs/libXrandr )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+# needs luaposix,slingshot,... not in tree
+RESTRICT=test
+
+S=${WORKDIR}/${P/_p/-}
+
+src_prepare() {
+ sed -e "/^CFLAGS=/s:=:+=:" \
+ -e "/^CFLAGS/{s:-Os:: ; s:-g::}" \
+ -e "/^LDFLAGS=/{s:=:+=: ; s:-Wl,--as-needed::}" \
+ -e "/^CC=/s:=:?=:" \
+ -e "s:^\(PREFIX=\).*$:\1${ROOT}usr:" \
+ -e "s:^\(ETCDIR=\).*$:\1${ROOT}etc/notion:" \
+ -e "s:^\(LIBDIR=\).*:\1\$(PREFIX)/$(get_libdir):" \
+ -e "s:^\(DOCDIR=\).*:\1\$(PREFIX)/share/doc/${PF}:" \
+ -e "s:^\(LUA_DIR=\).*$:\1\$(PREFIX)/usr:" \
+ -e "s:^\(VARDIR=\).*$:\1${ROOT}var/cache/${PN}:" \
+ -e "s:^\(X11_PREFIX=\).*:\1\$(PREFIX)/usr:" \
+ -i system-autodetect.mk || die
+ sed -e 's/gcc/$(CC)/g' \
+ -i ioncore/Makefile || die
+ export STRIPPROG=true
+
+ tc-export CC
+}
+
+src_configure() {
+ use nls || export DEFINES=" -DCF_NO_LOCALE -DCF_NO_GETTEXT"
+
+ if ! use xinerama ; then
+ sed -e 's/mod_xinerama//g' -i modulelist.mk || die
+ fi
+
+ if ! use xrandr ; then
+ sed -e 's/mod_xrandr//g' -i modulelist.mk || die
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)"
+}
+
+src_install() {
+ default
+
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/notion
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/notion.desktop
+}
+
+pkg_postinst() {
+ elog "If you want notion to have an ability to view a file based on its"
+ elog "guessed MIME type you should emerge app-misc/run-mailcap."
+}
diff --git a/x11-wm/notion/notion-3_p2015061300-r1.ebuild b/x11-wm/notion/notion-3_p2015061300-r1.ebuild
new file mode 100644
index 000000000000..4c9e78a1dda5
--- /dev/null
+++ b/x11-wm/notion/notion-3_p2015061300-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs readme.gentoo
+
+DESCRIPTION="Notion is a tiling, tabbed window manager for the X window system"
+HOMEPAGE="http://notion.sourceforge.net"
+SRC_URI="https://github.com/raboof/${PN}/archive/${PV/_p/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls xinerama +xrandr"
+
+RDEPEND=">=dev-lang/lua-5.1:0=
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-libs/libXinerama )
+ xrandr? ( x11-libs/libXrandr )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+# mod_xrandr references mod_xinerama
+REQUIRED_USE="xrandr? ( xinerama )"
+
+# needs luaposix,slingshot,... not in tree
+RESTRICT=test
+
+S=${WORKDIR}/${P/_p/-}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-pkg-config.patch"
+
+ sed -e "/^CFLAGS/{s: =: +=: ; s:-Os:: ; s:-g::}" \
+ -e "/^LDFLAGS/{s: =: +=: ; s:-Wl,--as-needed::}" \
+ -i system-autodetect.mk || die
+ echo > build/lua-detect.mk
+}
+
+src_configure() {
+ { echo "CFLAGS += -D_DEFAULT_SOURCE"
+ echo "PREFIX=${ROOT}usr"
+ echo "DOCDIR=\$(PREFIX)/share/doc/${PF}"
+ echo "ETCDIR=${ROOT}etc/${PN}"
+ echo "LIBDIR=\$(PREFIX)/$(get_libdir)"
+ echo "VARDIR=${ROOT}var/cache/${PN}"
+ echo "X11_PREFIX=${ROOT}usr"
+ echo "STRIPPROG=true"
+ echo "CC=$(tc-getCC)"
+ echo "AR=$(tc-getAR)"
+ echo "RANLIB=$(tc-getRANLIB)"
+ echo "LUA_MANUAL=1"
+ echo "LUA=\$(BINDIR)/lua"
+ echo "LUAC=\$(BINDIR)/luac"
+ echo "LUA_LIBS=\$(shell pkg-config --libs lua)"
+ echo "LUA_INCLUDES=\$(shell pkg-config --cflags)"
+ use nls || echo "DEFINES+=-DCF_NO_LOCALE -DCF_NO_GETTEXT"
+ } > system-local.mk
+
+ if ! use xinerama ; then
+ sed -e 's/mod_xinerama//g' -i modulelist.mk || die
+ fi
+
+ if ! use xrandr ; then
+ sed -e 's/mod_xrandr//g' -i modulelist.mk || die
+ sed -e '/mod_xrandr/d' \
+ -i etc/cfg_defaults.lua || die
+ fi
+}
+
+src_install() {
+ default
+
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/notion
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/notion.desktop
+
+ readme.gentoo_src_install
+}
+
+DOC_CONTENTS="If you want notion to have an ability to view a file based on its
+guessed MIME type you should emerge app-misc/run-mailcap."
diff --git a/x11-wm/notion/notion-9999.ebuild b/x11-wm/notion/notion-9999.ebuild
new file mode 100644
index 000000000000..61c251284170
--- /dev/null
+++ b/x11-wm/notion/notion-9999.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils git-r3 multilib toolchain-funcs readme.gentoo
+
+DESCRIPTION="Notion is a tiling, tabbed window manager for the X window system"
+HOMEPAGE="http://notion.sourceforge.net"
+EGIT_REPO_URI="https://github.com/raboof/${PN}.git"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS=""
+IUSE="nls xinerama +xrandr"
+
+RDEPEND=">=dev-lang/lua-5.1:0=
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-libs/libXinerama )
+ xrandr? ( x11-libs/libXrandr )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+# mod_xrandr references mod_xinerama
+REQUIRED_USE="xrandr? ( xinerama )"
+
+# needs luaposix,slingshot,... not in tree
+RESTRICT=test
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-3_p2015061300-pkg-config.patch"
+
+ sed -e "/^CFLAGS/{s: =: +=: ; s:-Os:: ; s:-g::}" \
+ -e "/^LDFLAGS/{s: =: +=: ; s:-Wl,--as-needed::}" \
+ -i system-autodetect.mk || die
+ echo > build/lua-detect.mk
+}
+
+src_configure() {
+ { echo "CFLAGS += -D_DEFAULT_SOURCE"
+ echo "PREFIX=${ROOT}usr"
+ echo "DOCDIR=\$(PREFIX)/share/doc/${PF}"
+ echo "ETCDIR=${ROOT}etc/${PN}"
+ echo "LIBDIR=\$(PREFIX)/$(get_libdir)"
+ echo "VARDIR=${ROOT}var/cache/${PN}"
+ echo "X11_PREFIX=${ROOT}usr"
+ echo "STRIPPROG=true"
+ echo "CC=$(tc-getCC)"
+ echo "AR=$(tc-getAR)"
+ echo "RANLIB=$(tc-getRANLIB)"
+ echo "LUA_MANUAL=1"
+ echo "LUA=\$(BINDIR)/lua"
+ echo "LUAC=\$(BINDIR)/luac"
+ echo "LUA_LIBS=\$(shell pkg-config --libs lua)"
+ echo "LUA_INCLUDES=\$(shell pkg-config --cflags)"
+ use nls || echo "DEFINES+=-DCF_NO_LOCALE -DCF_NO_GETTEXT"
+ } > system-local.mk
+
+ if ! use xinerama ; then
+ sed -e 's/mod_xinerama//g' -i modulelist.mk || die
+ fi
+
+ if ! use xrandr ; then
+ sed -e 's/mod_xrandr//g' -i modulelist.mk || die
+ sed -e '/mod_xrandr/d' \
+ -i etc/cfg_defaults.lua || die
+ fi
+}
+
+src_install() {
+ default
+
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/notion
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/notion.desktop
+
+ readme.gentoo_src_install
+}
+
+DOC_CONTENTS="If you want notion to have an ability to view a file based on its
+guessed MIME type you should emerge app-misc/run-mailcap."