summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/subtle
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/subtle')
-rw-r--r--x11-wm/subtle/Manifest1
-rw-r--r--x11-wm/subtle/metadata.xml26
-rw-r--r--x11-wm/subtle/subtle-0.11.3244.ebuild89
-rw-r--r--x11-wm/subtle/subtle-9999.ebuild89
4 files changed, 205 insertions, 0 deletions
diff --git a/x11-wm/subtle/Manifest b/x11-wm/subtle/Manifest
new file mode 100644
index 000000000000..55dc15e91c8c
--- /dev/null
+++ b/x11-wm/subtle/Manifest
@@ -0,0 +1 @@
+DIST subtle-0.11.3244.tar.gz 190549 SHA256 63f0a33ca187123f05f4f98b57fa05835d594ae9f018298e7e76e9a0be3f08b8 SHA512 3d6edd5cb1b5dcd058caeddf3ead024c7cce39684baca8bac9709683ce3130a5c8433cbe046d28dc7420637dd855a2b6775638097f78a5e701bb85e505e8167c WHIRLPOOL 1e555dbd211247c1c771dcd70a89fe0413bf4e0ad4255da0187c74dd05b22aeea738a299cf6b9eb0edb7801ab5b15e6e1f98d556fcd8ac654b3ed69a2a56dfbb
diff --git a/x11-wm/subtle/metadata.xml b/x11-wm/subtle/metadata.xml
new file mode 100644
index 000000000000..bf1ba89abd04
--- /dev/null
+++ b/x11-wm/subtle/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <longdescription lang="en">
+ subtle is a manual tiling window manager with a rather uncommon approach
+ of tiling: Instead of relying on predefined layouts, subtle divides the
+ screen into a grid with customizeable slots (called gravities). For
+ better understanding, the default config uses a 3x3 grid and maps each
+ gravity to one key of the numpad. With those keys, windows can be moved
+ directly to the desired gravity - the same can be done with tagging
+ rules in the config.
+
+ Another unique concept is the strict tagging: Unlike other tiling window
+ managers, subtle doesn't allow weak tagging and always maps windows to
+ virtual desktops (called views) with matching tags, regardless of the
+ current active view.
+ </longdescription>
+ <use>
+ <flag name='xrandr'>Enable support for the X RandR extension</flag>
+ <flag name='xtest'>Enable support for the XTest extension</flag>
+ </use>
+</pkgmetadata>
diff --git a/x11-wm/subtle/subtle-0.11.3244.ebuild b/x11-wm/subtle/subtle-0.11.3244.ebuild
new file mode 100644
index 000000000000..6f5f6c65e2f1
--- /dev/null
+++ b/x11-wm/subtle/subtle-0.11.3244.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+USE_RUBY="ruby20 ruby21 ruby22"
+
+inherit ruby-ng toolchain-funcs
+
+if [[ ${PV} == "9999" ]]; then
+ EHG_REPO_URI="http://hg.subforge.org/subtle"
+ EHG_CHECKOUT_DIR=${S}/all
+ inherit mercurial
+else
+ SRC_URI="http://dev.gentoo.org/~radhermit/dist/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A manual tiling window manager"
+HOMEPAGE="http://subforge.org/projects/subtle/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug doc +xft xinerama xpm +xrandr +xtest"
+
+RDEPEND="x11-libs/libX11
+ xft? ( x11-libs/libXft )
+ xinerama? ( x11-libs/libXinerama )
+ xpm? ( x11-libs/libXpm )
+ xtest? ( x11-libs/libXtst )
+ xrandr? ( x11-libs/libXrandr )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+ruby_add_rdepend "dev-ruby/archive-tar-minitar"
+ruby_add_bdepend "dev-ruby/rake"
+
+all_ruby_unpack() {
+ if [[ ${PV} == "9999" ]]; then
+ mercurial_src_unpack
+ else
+ default
+ fi
+}
+
+each_ruby_configure() {
+ local myconf
+ use debug && myconf+=" debug=yes" || myconf+=" debug=no"
+ use xft && myconf+=" xft=yes" || myconf+=" xft=no"
+ use xinerama && myconf+=" xinerama=yes" || myconf+=" xinerama=no"
+ use xpm && myconf+=" xpm=yes" || myconf+=" xpm=no"
+ use xtest && myconf+=" xtest=yes" || myconf+=" xtest=no"
+ use xrandr && myconf+=" xrandr=yes" || myconf+=" xrandr=no"
+
+ ${RUBY} -S rake -v CC="$(tc-getCC)" destdir="${D}" ${myconf} config || die
+}
+
+each_ruby_compile() {
+ ${RUBY} -S rake -v build || die
+}
+
+all_ruby_compile() {
+ use doc && { rake rdoc || die ; }
+}
+
+each_ruby_install() {
+ ${RUBY} -S rake -v install || die
+}
+
+all_ruby_install() {
+ dodir /etc/X11/Sessions
+ cat <<-EOF > "${D}/etc/X11/Sessions/${PN}"
+ #!/bin/sh
+ exec /usr/bin/subtle
+ EOF
+ fperms a+x /etc/X11/Sessions/${PN}
+
+ insinto /usr/share/xsessions
+ doins data/${PN}.desktop
+
+ dodoc AUTHORS NEWS
+
+ use doc && dohtml -r html/*
+}
+
+pkg_postinst() {
+ elog "Note that surserver will currently not work since dev-ruby/datamapper"
+ elog "is not in the tree."
+}
diff --git a/x11-wm/subtle/subtle-9999.ebuild b/x11-wm/subtle/subtle-9999.ebuild
new file mode 100644
index 000000000000..6f5f6c65e2f1
--- /dev/null
+++ b/x11-wm/subtle/subtle-9999.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+USE_RUBY="ruby20 ruby21 ruby22"
+
+inherit ruby-ng toolchain-funcs
+
+if [[ ${PV} == "9999" ]]; then
+ EHG_REPO_URI="http://hg.subforge.org/subtle"
+ EHG_CHECKOUT_DIR=${S}/all
+ inherit mercurial
+else
+ SRC_URI="http://dev.gentoo.org/~radhermit/dist/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A manual tiling window manager"
+HOMEPAGE="http://subforge.org/projects/subtle/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug doc +xft xinerama xpm +xrandr +xtest"
+
+RDEPEND="x11-libs/libX11
+ xft? ( x11-libs/libXft )
+ xinerama? ( x11-libs/libXinerama )
+ xpm? ( x11-libs/libXpm )
+ xtest? ( x11-libs/libXtst )
+ xrandr? ( x11-libs/libXrandr )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+ruby_add_rdepend "dev-ruby/archive-tar-minitar"
+ruby_add_bdepend "dev-ruby/rake"
+
+all_ruby_unpack() {
+ if [[ ${PV} == "9999" ]]; then
+ mercurial_src_unpack
+ else
+ default
+ fi
+}
+
+each_ruby_configure() {
+ local myconf
+ use debug && myconf+=" debug=yes" || myconf+=" debug=no"
+ use xft && myconf+=" xft=yes" || myconf+=" xft=no"
+ use xinerama && myconf+=" xinerama=yes" || myconf+=" xinerama=no"
+ use xpm && myconf+=" xpm=yes" || myconf+=" xpm=no"
+ use xtest && myconf+=" xtest=yes" || myconf+=" xtest=no"
+ use xrandr && myconf+=" xrandr=yes" || myconf+=" xrandr=no"
+
+ ${RUBY} -S rake -v CC="$(tc-getCC)" destdir="${D}" ${myconf} config || die
+}
+
+each_ruby_compile() {
+ ${RUBY} -S rake -v build || die
+}
+
+all_ruby_compile() {
+ use doc && { rake rdoc || die ; }
+}
+
+each_ruby_install() {
+ ${RUBY} -S rake -v install || die
+}
+
+all_ruby_install() {
+ dodir /etc/X11/Sessions
+ cat <<-EOF > "${D}/etc/X11/Sessions/${PN}"
+ #!/bin/sh
+ exec /usr/bin/subtle
+ EOF
+ fperms a+x /etc/X11/Sessions/${PN}
+
+ insinto /usr/share/xsessions
+ doins data/${PN}.desktop
+
+ dodoc AUTHORS NEWS
+
+ use doc && dohtml -r html/*
+}
+
+pkg_postinst() {
+ elog "Note that surserver will currently not work since dev-ruby/datamapper"
+ elog "is not in the tree."
+}