summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-27 19:02:11 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-27 19:40:41 +0100
commit76fd4de2a8574b255cb8c84fd769a2eabc8b3aca (patch)
tree13a5e8bdfe157a912508c629588c4d4d1bee6aa4 /x11-wm/wmfs/wmfs-99999999.ebuild
parentdev-lang/orc: add USE=gtk-doc, other ebuild touchups (diff)
downloadgentoo-76fd4de2a8574b255cb8c84fd769a2eabc8b3aca.tar.gz
gentoo-76fd4de2a8574b255cb8c84fd769a2eabc8b3aca.tar.bz2
gentoo-76fd4de2a8574b255cb8c84fd769a2eabc8b3aca.zip
x11-wm/wmfs: Fix CFLAGS=-fno-common
- EAPI=7 - Convert sed script to patch - Fix W and event_handle for CFLAGS=-fno-common - Respect CC - Apply one lingering upstream patch Package-Manager: Portage-2.3.85, Repoman-2.3.20 Closes: https://bugs.gentoo.org/show_bug.cgi?id=706654 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-wm/wmfs/wmfs-99999999.ebuild')
-rw-r--r--x11-wm/wmfs/wmfs-99999999.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/x11-wm/wmfs/wmfs-99999999.ebuild b/x11-wm/wmfs/wmfs-99999999.ebuild
index f152990663f4..a2a1959136ed 100644
--- a/x11-wm/wmfs/wmfs-99999999.ebuild
+++ b/x11-wm/wmfs/wmfs-99999999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils git-r3
+EAPI=7
+inherit git-r3 toolchain-funcs
DESCRIPTION="Window Manager From Scratch, A tiling window manager highly configurable"
HOMEPAGE="https://github.com/xorg62/wmfs"
@@ -26,15 +26,14 @@ DEPEND="
virtual/pkgconfig
x11-base/xorg-proto
"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-99999999-desktop.patch
-
- sed -i -e '/^which dpkg/s|.*|false|g' configure || die
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-99999999-Debian.patch
+ "${FILESDIR}"/${PN}-99999999-desktop.patch
+ "${FILESDIR}"/${PN}-99999999-fno-common.patch
+)
src_configure() {
+ tc-export CC
# not autotools based
local ECHO
for ECHO in echo ''; do