summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-13 05:44:36 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-13 06:54:32 +0200
commitc3e7a3623684e769bbd7eeddea44f7abdca5d55b (patch)
tree000af2bef64183d8569a95e903d395509b3aa8a3 /x11-wm
parentdev-python/matplotlib: Bump to 3.9.2 (diff)
downloadgentoo-c3e7a3623684e769bbd7eeddea44f7abdca5d55b.tar.gz
gentoo-c3e7a3623684e769bbd7eeddea44f7abdca5d55b.tar.bz2
gentoo-c3e7a3623684e769bbd7eeddea44f7abdca5d55b.zip
x11-wm/qtile: Bump to 0.28.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/qtile/Manifest1
-rw-r--r--x11-wm/qtile/qtile-0.28.1.ebuild114
2 files changed, 115 insertions, 0 deletions
diff --git a/x11-wm/qtile/Manifest b/x11-wm/qtile/Manifest
index 3595046c1c0e..adbcb24c266c 100644
--- a/x11-wm/qtile/Manifest
+++ b/x11-wm/qtile/Manifest
@@ -3,3 +3,4 @@ DIST qtile-0.25.0.tar.gz 569312 BLAKE2B 3841ca41755f37191c659c039da45279393b5bbe
DIST qtile-0.26.0.tar.gz 593712 BLAKE2B c7f43813b42d1009f0f542ef0964e07cbb3286af6af058e168d62d1e32c7dfaf51fe537568b77d5b21a1701c1ce159b63f86b6ba4ae3bf5482125562c91c5d3a SHA512 0b28125e3111493a90c5ae993a516dccf984f794ba9c0424c9366a3b04073fdf06deba42e59e8b1e33b60e5686730e0ed010161943a4a77ab4b36e4c7c710a61
DIST qtile-0.27.0.tar.gz 598603 BLAKE2B 79f876d290398839e83b14304956f7bbe5a5bb70faccae6e090dd37477728c9067fc9d6797b498b5a8cd1a35f08fb4bc85ee3609a244f955d2b15b79f30d96c4 SHA512 62daa4ec51239506e2a860b9d021e2838edba887c7ff45bbede36428a399343470b9357f4aab373d13279c933ae19c3bd2b03bb520862386298a1258fe505127
DIST qtile-0.28.0.tar.gz 601157 BLAKE2B c2ec5ac92484ad8124a2eeb0aa57050ff529f0223cb889a6da81291a2c52002e989d94667cc3b34449284ca52ca50186379619c05bf83adeb6dc5dfa8c4a6dc1 SHA512 aad0f260ab8f8e974e12f385324e7eadab6a314c9eb1b3114bbfc928819f7a764eb8243e7ed6545ca87f38b223e00d525cba5e8b2430c35aa93370c9fecd0947
+DIST qtile-0.28.1.tar.gz 601217 BLAKE2B 04f24c5b628e1c3d0eca395135ef0d0093af5a57d23aea751e76197da4f148ae679a9fb650e2589e5f2e253673cab86642e3f0695ac219641c65192eb9a37274 SHA512 95b4d95206aeac4bb59d47c94eb93b55ac413681050345a0d61cdb19b71dd785bb6c13c0161757b9bfa5e8d0ce345fcf64eea04fc44b2f596a65b70f5da5d32e
diff --git a/x11-wm/qtile/qtile-0.28.1.ebuild b/x11-wm/qtile/qtile-0.28.1.ebuild
new file mode 100644
index 000000000000..e8473373841c
--- /dev/null
+++ b/x11-wm/qtile/qtile-0.28.1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="A full-featured, hackable tiling window manager written in Python"
+HOMEPAGE="
+ https://qtile.org/
+ https://github.com/qtile/qtile/
+ https://pypi.org/project/qtile/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="pulseaudio wayland"
+
+RDEPEND="
+ >=dev-python/cairocffi-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]
+ dev-python/dbus-next[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ >=dev-python/xcffib-1.4.0[${PYTHON_USEDEP}]
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/libnotify[introspection]
+ x11-libs/pango
+ pulseaudio? (
+ dev-python/pulsectl-asyncio[${PYTHON_USEDEP}]
+ media-sound/pulseaudio
+ )
+ wayland? (
+ >=dev-python/pywayland-0.4.17[${PYTHON_USEDEP}]
+ >=dev-python/pywlroots-0.17[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ dev-python/cffi[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/libcst[${PYTHON_USEDEP}]
+ media-gfx/imagemagick[X]
+ x11-base/xorg-server[xephyr,xvfb]
+ )
+ wayland? (
+ >=dev-python/pywayland-0.4.17[${PYTHON_USEDEP}]
+ >=dev-python/pywlroots-0.17[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s/can_import(\"wlroots.ffi_build\")/$(usex wayland True False)/" \
+ -i setup.py || die
+
+ # some tests expect bin/qtile
+ mkdir bin || die
+ cat >> bin/qtile <<-EOF || die
+ #!/bin/sh
+ exec qtile "\${@}"
+ EOF
+ chmod +x bin/qtile || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ local -x CFFI_TMPDIR=${T}
+ distutils-r1_src_compile
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # mypy stuff
+ test/test_check.py
+ test/migrate/test_check_migrations.py
+ # TODO: this test clearly requires x11 — so why is wayland
+ # variant being run?
+ 'test/backend/x11/test_window.py::test_urgent_hook_fire[wayland-2]'
+ )
+
+ # force usage of built module
+ rm -rf libqtile || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x TZ=UTC
+ nonfatal epytest --backend=x11 $(usev wayland '--backend=wayland') ||
+ die -n "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGELOG README.rst )
+ distutils-r1_python_install_all
+
+ insinto /usr/share/xsessions
+ doins resources/qtile.desktop
+
+ insinto /usr/share/wayland-sessions
+ doins resources/qtile-wayland.desktop
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/${PN}-session-r1 ${PN}
+}