summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-01 17:26:50 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-01 17:26:50 +0100
commit7b45afa8e9490271a57d53946d822d2ffe9d5e47 (patch)
treeeadc47e013775d0cd19afa9ec0771e6914b9baff /xfce-base/xfconf
parentxfce-base/xfconf: Remove old (diff)
downloadgentoo-7b45afa8e9490271a57d53946d822d2ffe9d5e47.tar.gz
gentoo-7b45afa8e9490271a57d53946d822d2ffe9d5e47.tar.bz2
gentoo-7b45afa8e9490271a57d53946d822d2ffe9d5e47.zip
xfce-base/xfconf: Bump to 4.19.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/xfconf')
-rw-r--r--xfce-base/xfconf/Manifest1
-rw-r--r--xfce-base/xfconf/xfconf-4.19.5.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/xfce-base/xfconf/Manifest b/xfce-base/xfconf/Manifest
index 5c6d52a802b4..b264f89ea4f3 100644
--- a/xfce-base/xfconf/Manifest
+++ b/xfce-base/xfconf/Manifest
@@ -1,2 +1,3 @@
DIST xfconf-4.18.3.tar.bz2 648479 BLAKE2B 021198bba84c651f05cf47a1034617e088dcce6502eac6f0f160f8000e2309bac5f44b57cc0a4156f907a25002cc3c539ab0c16fc5b3018bbc8ae9a58b212133 SHA512 e1aa133f79ea584af067369f6fd059cd444c4743270ed90a8b0dfe158f7ae6fbc78af62fab67c64674060c2fd1404f06602ac8c019b0db8b70779a17fde4a327
DIST xfconf-4.19.4.tar.bz2 762535 BLAKE2B 308c70595ea21fd80e16fb51caf8a87d69ed722875b2a45d8fac45fa79081d8c1a95babd55f359457dd8b0f51b6f69be0be6f86edde3d853f6312c56d3789313 SHA512 291b9816de71a50cd39e428e6468d077c1dd4470aa40715e8ab7f895d360e190145881006003e135703776ca26cf07f7c902d9444723fb983edbdc0e16c07d4d
+DIST xfconf-4.19.5.tar.bz2 763032 BLAKE2B e8c58ad133caa764bea7272ab0c5f0695db9372117f20ba40d2eae8cd95cb1d947add36cc527eab168d105cbd1bff1aa3b78268e6e210296d70133a4accc4853 SHA512 9239c5bac17c1b7d3e9364a34cb6c06aa46a83b50839cb03895873b9be382933ca18588c07fe59d28b026f384272f880394032e12d42779710411e69f920c3ef
diff --git a/xfce-base/xfconf/xfconf-4.19.5.ebuild b/xfce-base/xfconf/xfconf-4.19.5.ebuild
new file mode 100644
index 000000000000..a2c9f5c21a6b
--- /dev/null
+++ b/xfce-base/xfconf/xfconf-4.19.5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 vala
+
+DESCRIPTION="A configuration management system for Xfce"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/xfconf/start
+ https://gitlab.xfce.org/xfce/xfconf/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="debug +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ >=dev-libs/glib-2.72.0
+ sys-apps/dbus
+ >=xfce-base/libxfce4util-4.17.3:=
+ introspection? ( >=dev-libs/gobject-introspection-1.66:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable vala)
+ $(use_enable debug checks)
+ --with-bash-completion-dir="$(get_bashcompdir)"
+ )
+
+ use vala && vala_setup
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ local service_dir=${HOME}/.local/share/dbus-1/services
+ mkdir -p "${service_dir}" || die
+ cat > "${service_dir}/org.xfce.Xfconf.service" <<-EOF || die
+ [D-BUS Service]
+ Name=org.xfce.Xfconf
+ Exec=${S}/xfconfd/xfconfd
+ EOF
+
+ (
+ # start isolated dbus session bus
+ dbus_data=$(dbus-launch --sh-syntax) || exit
+ eval "${dbus_data}"
+
+ # -j>1 often hangs
+ # https://gitlab.xfce.org/xfce/xfconf/-/issues/13
+ nonfatal emake -j1 check
+ ret=${?}
+
+ kill "${DBUS_SESSION_BUS_PID}"
+ exit "${ret}"
+ ) || die
+}
+
+src_install() {
+ default
+ find "${D}" -type f -name '*.la' -delete || die
+}