summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-15 16:04:30 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-15 17:27:13 +0200
commit168a69586bcd85547a510647e9a598f88c5a0fa2 (patch)
treef3fc853a470993dfbeae9504ea9f180eb93dd8f8 /xfce-base
parentsys-libs/glibc: stable 2.37-r7 for sparc, bug #915142 (diff)
downloadgentoo-168a69586bcd85547a510647e9a598f88c5a0fa2.tar.gz
gentoo-168a69586bcd85547a510647e9a598f88c5a0fa2.tar.bz2
gentoo-168a69586bcd85547a510647e9a598f88c5a0fa2.zip
xfce-base/exo: Bump to 4.19.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/exo/Manifest1
-rw-r--r--xfce-base/exo/exo-4.19.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/xfce-base/exo/Manifest b/xfce-base/exo/Manifest
index 586c0b60b777..cb4f69b8f241 100644
--- a/xfce-base/exo/Manifest
+++ b/xfce-base/exo/Manifest
@@ -1 +1,2 @@
DIST exo-4.18.0.tar.bz2 896849 BLAKE2B 99cd22b9f2c806907449afdd640abd85be2ec37269d0436a20300ac88ee4fbe39807e39ba51ae8fe82d621c478d65d1f452209779e7d48caee899305b40f3a27 SHA512 32f3a319ff31a37cdaf8e2e7bdbdbaa9b797d6731a27854838b47d6078f45af83ed1a664aef4663f616fd9abcae9233c6f68ab2cc18599f1b2ced487602c51ce
+DIST exo-4.19.0.tar.bz2 1095228 BLAKE2B e0a368032d3cb148a9bda96e5eeb6a9364a568e809f1c0c31d13e82e1357c22e401a8ec486e19da8001fe7ff7570870fecd5564d2ccdc38947ddb51e5eec00df SHA512 656ec021c19618daafd80df6701e7076ad167520388cbc1727d22da9c6b4eaa4f7e12b53f6131f2d2e10986b0440cbf808aeb6914c1a91d2e7af711c015967fc
diff --git a/xfce-base/exo/exo-4.19.0.ebuild b/xfce-base/exo/exo-4.19.0.ebuild
new file mode 100644
index 000000000000..1f0b2f08307d
--- /dev/null
+++ b/xfce-base/exo/exo-4.19.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/exo/start
+ https://gitlab.xfce.org/xfce/exo/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ >=x11-libs/gtk+-3.24.0:3
+ >=xfce-base/libxfce4ui-4.15.1:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.17.2:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/gtk-doc-am
+ >=dev-util/xfce4-dev-tools-4.16.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}