summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-18 18:43:59 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-18 18:45:47 +0200
commit56427335541d9eb89145429da3e231311ee614fd (patch)
treee84fba52f0a4a3ea7dbd7976104807eb888b89fe /xfce-extra/xfce4-timer-plugin
parentxfce-base/xfce4-power-manager: Bump to 4.19.0 (diff)
downloadgentoo-56427335541d9eb89145429da3e231311ee614fd.tar.gz
gentoo-56427335541d9eb89145429da3e231311ee614fd.tar.bz2
gentoo-56427335541d9eb89145429da3e231311ee614fd.zip
xfce-extra/xfce4-timer-plugin: Bump to 1.7.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-timer-plugin')
-rw-r--r--xfce-extra/xfce4-timer-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-timer-plugin/xfce4-timer-plugin-1.7.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-timer-plugin/Manifest b/xfce-extra/xfce4-timer-plugin/Manifest
index eea73753ee5b..31ea209db63e 100644
--- a/xfce-extra/xfce4-timer-plugin/Manifest
+++ b/xfce-extra/xfce4-timer-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-timer-plugin-1.7.1.tar.bz2 405053 BLAKE2B 1efb88f9b4e7d1ace747950f97c1d0beaf7e9194bab639c4f8eb650378cd216f621fe30e7fbb874e73acffd1c3b30048754f07ed8fb64e96260fb831f3ff62be SHA512 4887dc2c524a8b749a20449dd491dc8f12f8babb26c64cecf33ae56b45d2446128cb65c25f11d534278ad39a2adf7ab718714e1bfa613fd39713e44642030c16
+DIST xfce4-timer-plugin-1.7.2.tar.bz2 414526 BLAKE2B 419544e8088b518cd597c6394dafe798cffcfaeefcfe4fbd11f75e9709ad7990e44b5cddca438bb4960502fab8bc6127e3e37d2899e892a1f4ff980e97a48f5a SHA512 11a3b146c56f1526530b7f810c76ba95ef4dc7c113fa0ad2839494a5bc66c09f4a3ff966bc5d76055482a284c6c082b08a4b6af4684e5ccdec67946b0cdd820d
diff --git a/xfce-extra/xfce4-timer-plugin/xfce4-timer-plugin-1.7.2.ebuild b/xfce-extra/xfce4-timer-plugin/xfce4-timer-plugin-1.7.2.ebuild
new file mode 100644
index 000000000000..daab347695f0
--- /dev/null
+++ b/xfce-extra/xfce4-timer-plugin/xfce4-timer-plugin-1.7.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A simple timer plug-in for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-timer-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-timer-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.26.0
+ >=x11-libs/gtk+-3.20.0:3
+ >=xfce-base/libxfce4ui-4.12.0:=
+ >=xfce-base/libxfce4util-4.12.0:=
+ >=xfce-base/xfce4-panel-4.10.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}