summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-15 11:28:23 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-15 11:36:19 +0200
commite638ab8f2cb028061aa6639cfdb79e60077100f1 (patch)
tree7227148cc90784e30f01027e75ff12fe9a0d6fed /xfce-extra/xfdashboard
parentdev-lang/python: Report ABI breakage in postinst (diff)
downloadgentoo-e638ab8f2cb028061aa6639cfdb79e60077100f1.tar.gz
gentoo-e638ab8f2cb028061aa6639cfdb79e60077100f1.tar.bz2
gentoo-e638ab8f2cb028061aa6639cfdb79e60077100f1.zip
xfce-extra/xfdashboard: Bump to 0.9.91
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfdashboard')
-rw-r--r--xfce-extra/xfdashboard/Manifest1
-rw-r--r--xfce-extra/xfdashboard/xfdashboard-0.9.91.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/xfce-extra/xfdashboard/Manifest b/xfce-extra/xfdashboard/Manifest
index 76a8aa89010d..20e8e8baf3fe 100644
--- a/xfce-extra/xfdashboard/Manifest
+++ b/xfce-extra/xfdashboard/Manifest
@@ -1,2 +1,3 @@
DIST xfdashboard-0.9.5.tar.bz2 3397335 BLAKE2B 5e65206c73f85ce9d4305e459ca837c287c43f95bbb16df632109eee998524d5858c5de8a6c390713d118ed3f7bb7f184d88650cec78e7bc03a6859fe7e44a39 SHA512 9929bdcef6a9766799b900b61e009b43ef901f1aebd6dbe9291c3342edebfa1d599340222da25bbac17810f4ef7b001743b4daec0c25f585203f0b69f2bc17d6
DIST xfdashboard-0.9.90.tar.bz2 3411068 BLAKE2B 6deee633c03d0265f34532edd20d5e29fe270aa82bcd197bbe398138977fa95c5e502b0484c835a43b93b34defcfedf2d717cf11ea8b25021803e25213731a31 SHA512 5fd4a67998477c2a168d15ca05f173b42eb1a87432228feea461ec563f0662441f17df7ac6efd4b4afd181eba4e99927adc018fca0f2bf8df804fc52c87b4034
+DIST xfdashboard-0.9.91.tar.bz2 3421906 BLAKE2B 10b5bb09fa4d4bbbe242d1d36ad073e08384845e67331994c9ae622d70de27e873ce2f476d8baebde4bd4ae55db77cb35336a1a1725b4e40b1c814066ab4e72c SHA512 56e18c70a1282ff8f45df8304993fdd5e9097429f7edd6b9c7fc5c20681d1043b57251b5ce327346e612bc1069823ba4c76a5665529eeb2807e106c8fa747ba6
diff --git a/xfce-extra/xfdashboard/xfdashboard-0.9.91.ebuild b/xfce-extra/xfdashboard/xfdashboard-0.9.91.ebuild
new file mode 100644
index 000000000000..f725a7560151
--- /dev/null
+++ b/xfce-extra/xfdashboard/xfdashboard-0.9.91.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Maybe a GNOME shell like dashboard for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfdashboard/start"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=x11-libs/gtk+-3.2:3
+ >=media-libs/clutter-1.12:1.0=[gtk]
+ >=x11-libs/libwnck-3:3=
+ x11-libs/libX11:=
+ x11-libs/libXcomposite:=
+ x11-libs/libXdamage:=
+ x11-libs/libXinerama:=
+ >=xfce-base/garcon-0.2.0:=
+ >=xfce-base/libxfce4ui-4.10:=
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/xfconf-4.14:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}