summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-03 00:07:56 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-03 00:07:56 +0100
commit49bfc99d6371996c0aca4b55a33933103126db4f (patch)
treecf313304a178bf3022ad3cea3ff49d2ca957dbb4 /xfce-extra
parentvirtual/gnustep-back: Stabilize 0.28.0 sparc, #761070 (diff)
downloadgentoo-49bfc99d6371996c0aca4b55a33933103126db4f.tar.gz
gentoo-49bfc99d6371996c0aca4b55a33933103126db4f.tar.bz2
gentoo-49bfc99d6371996c0aca4b55a33933103126db4f.zip
xfce-extra/xfce4-indicator-plugin: Bump to 2.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-indicator-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-indicator-plugin/Manifest b/xfce-extra/xfce4-indicator-plugin/Manifest
index 3363bfd026ae..17c55831c99b 100644
--- a/xfce-extra/xfce4-indicator-plugin/Manifest
+++ b/xfce-extra/xfce4-indicator-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-indicator-plugin-2.3.4.tar.bz2 406991 BLAKE2B 3d499f9f923e9cc51b25e2bed3dc6dfb6d4413c90d0a1afeacd14e0d1f33c9f9d5bdd6bdeb03a3e61bef0c3ec8cb1d1c766d89d921aaf9610bc797dc99a12219 SHA512 b1fd065c8221ae91d95b540411317cd67bb9b26d46c7cfe85ec90d7ccdcd11e7b8832008c8b6fb5c257e0b1a08360f00ad9da5520108024cc36c63d865ffdca6
+DIST xfce4-indicator-plugin-2.4.0.tar.bz2 389228 BLAKE2B 6f627663d0a432ee74e871b55656c119f99c315d2f5095fd24a9eefc9338d280d5c371153377d575bc926707f30dc0602c7033bf09acdba1e247356b341393d5 SHA512 5b6e82d85357cec689f23a6cf69d379db9425956a531d8295a23adf52b1e00e3cd8acd822b13ab05d80321ff739c96aadc6e7526ec275421c341446e58a5fbab
diff --git a/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4.0.ebuild b/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4.0.ebuild
new file mode 100644
index 000000000000..b93f7bda74df
--- /dev/null
+++ b/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils
+
+DESCRIPTION="A panel plugin that uses indicator-applet to show new messages"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-indicator-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/libindicator-12.10.1:3=
+ >=x11-libs/gtk+-3.18:3=
+ x11-libs/libX11:=
+ >=xfce-base/libxfce4ui-4.11:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.11:=
+ >=xfce-base/xfce4-panel-4.11:=
+ >=xfce-base/xfconf-4.13:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ # libido3-13.10.0 needs ubuntu-private.h from Ubuntu's GTK+ 3.x
+ --disable-ido
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}