summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pymdown-extensions/Manifest1
-rw-r--r--dev-python/pymdown-extensions/pymdown-extensions-10.8.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pymdown-extensions/Manifest b/dev-python/pymdown-extensions/Manifest
index 79f25d60fdbd..761a3f1d3e53 100644
--- a/dev-python/pymdown-extensions/Manifest
+++ b/dev-python/pymdown-extensions/Manifest
@@ -1 +1,2 @@
DIST pymdown_extensions-10.7.1.tar.gz 811769 BLAKE2B ed2195a1a2262b96d444dd7d60c6330a6670cbe44a0f00f4c5a1dd80f4d2f13f0202adac5505d2fd5b6b5b02300e2d0bc62680fd92f3c00363c4123f02151a0a SHA512 60dce8fafb1935ab3d42320f9b6a3db9b60f4f4d4585b79f123103183f2a2ae9ed1256ae84992ad14b20f6969519a9c1a1b916c301a63715f867e8136be5eb2b
+DIST pymdown_extensions-10.8.tar.gz 811981 BLAKE2B 98e95166fa4fdb0ed7049104f2a49995e43a40fb5118673ee8f47b999c4881a8468ce98e6381fd78d58b15218c444c8c3270450a845e5025cab8861d1746fcdb SHA512 24b5d2211941a771c7f3b6fb9d6eb2db2c3b38906c4c37f2fa385e5b28140a60dc163256e903fd4df4144b05d9c1c4c0c296fe76ceb290969674753b87de7466
diff --git a/dev-python/pymdown-extensions/pymdown-extensions-10.8.ebuild b/dev-python/pymdown-extensions/pymdown-extensions-10.8.ebuild
new file mode 100644
index 000000000000..30aebcd368e1
--- /dev/null
+++ b/dev-python/pymdown-extensions/pymdown-extensions-10.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Extensions for Python Markdown"
+HOMEPAGE="
+ https://github.com/facelessuser/pymdown-extensions/
+ https://pypi.org/project/pymdown-extensions/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/markdown-3.6[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/pygments-2.12.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # broken on pypy3; unfortunately, the parametrization is based
+ # on indexes and these are pretty random, so we need to remove it
+ # entirely
+ # TODO: restore it when pypy with a fix is in Gentoo
+ # https://github.com/pypy/pypy/issues/4920
+ rm "tests/extensions/superfences/superfences (normal).txt" || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}