summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-libs/zlib-ng/zlib-ng-2.0.1-r1.ebuild14
1 files changed, 14 insertions, 0 deletions
diff --git a/sys-libs/zlib-ng/zlib-ng-2.0.1-r1.ebuild b/sys-libs/zlib-ng/zlib-ng-2.0.1-r1.ebuild
index c00074bbf786..291818622291 100644
--- a/sys-libs/zlib-ng/zlib-ng-2.0.1-r1.ebuild
+++ b/sys-libs/zlib-ng/zlib-ng-2.0.1-r1.ebuild
@@ -18,6 +18,8 @@ IUSE="compat ${CPU_USE[@]} test"
RESTRICT="!test? ( test )"
+RDEPEND="compat? ( !sys-libs/zlib )"
+
src_prepare() {
cmake_src_prepare
@@ -67,3 +69,15 @@ src_configure() {
cmake_src_configure
}
+
+src_install() {
+ cmake_src_install
+
+ if use compat ; then
+ ewarn "zlib-ng is experimental and replacing the system zlib is dangerous"
+ ewarn "Please be careful!"
+ ewarn
+ ewarn "The following link explains the guarantees (and what is NOT guaranteed):"
+ ewarn "https://github.com/zlib-ng/zlib-ng/blob/2.0.x/PORTING.md"
+ fi
+}