summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-ftp/proftpd/files/proftpd-1.3.6c-gcc-10.patch21
-rw-r--r--net-ftp/proftpd/proftpd-1.3.6c.ebuild1
2 files changed, 22 insertions, 0 deletions
diff --git a/net-ftp/proftpd/files/proftpd-1.3.6c-gcc-10.patch b/net-ftp/proftpd/files/proftpd-1.3.6c-gcc-10.patch
new file mode 100644
index 000000000000..c3ee704c085c
--- /dev/null
+++ b/net-ftp/proftpd/files/proftpd-1.3.6c-gcc-10.patch
@@ -0,0 +1,21 @@
+--- a/contrib/mod_quotatab.c
++++ b/contrib/mod_quotatab.c
+@@ -50,6 +50,7 @@ typedef struct regtab_obj {
+ module quotatab_module;
+
+ /* Quota objects for the current session */
++quota_deltas_t quotatab_deltas;
+ static quota_table_t *limit_tab = NULL;
+ static quota_limit_t sess_limit;
+
+--- a/contrib/mod_quotatab.h
++++ b/contrib/mod_quotatab.h
+@@ -188,7 +188,7 @@ typedef struct table_obj {
+ #define QUOTATAB_TALLY_SRC 0x0002
+
+ /* Quota objects for the current session. */
+-quota_deltas_t quotatab_deltas;
++extern quota_deltas_t quotatab_deltas;
+
+ /* Function prototypes necessary for quotatab sub-modules */
+ int quotatab_log(const char *, ...)
diff --git a/net-ftp/proftpd/proftpd-1.3.6c.ebuild b/net-ftp/proftpd/proftpd-1.3.6c.ebuild
index 5c8f9eb610d3..d2441f41e29c 100644
--- a/net-ftp/proftpd/proftpd-1.3.6c.ebuild
+++ b/net-ftp/proftpd/proftpd-1.3.6c.ebuild
@@ -71,6 +71,7 @@ S="${WORKDIR}/${P/_/}"
PATCHES=(
"${FILESDIR}"/${PN}-1.3.6-use-trace.patch
"${FILESDIR}"/${PN}-1.3.6a-fix-libcheck.patch
+ "${FILESDIR}"/${PN}-1.3.6c-gcc-10.patch
)
RESTRICT=test # tests corrupt memory. need to be fixed upstream first