summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/pastel/Manifest1
-rw-r--r--dev-ruby/pastel/pastel-0.7.3.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/pastel/Manifest b/dev-ruby/pastel/Manifest
index 4140a8b22cda..535982918250 100644
--- a/dev-ruby/pastel/Manifest
+++ b/dev-ruby/pastel/Manifest
@@ -1 +1,2 @@
DIST pastel-0.7.2.gem 49152 BLAKE2B 37380dd9f44f2e816628bda1ed359aeaa961c9b1c18a0e76b4b04fea39906e53601aba17fd2c1cd0571357697296ee1afce3a52fbdc33475a1560c3c2f52e567 SHA512 83cf7ef04800a77ee91692de5b89c6bfe6590be72f24dda74ee53809b14b7e2e9c6e70e9a829eff7aa8dd02a191057dc5f5c5528d36fe2bfd211e1c499d276f0
+DIST pastel-0.7.3.gem 22016 BLAKE2B 0e883969446c9c64389a6280de3f94c6e4970321051bfa718698ea0ce2594ac9a36e32f29946fbceb98015644d529c8dbdafb9f1fdb2fe0825b3d9477b75f4b8 SHA512 71cefdac478c709c8d4899021438945c841e4eada2411aae3165e8444835bd9aed27ad9083fe223b115206311fa579d4160cde136bd7a21df5bdcf2589234177
diff --git a/dev-ruby/pastel/pastel-0.7.3.ebuild b/dev-ruby/pastel/pastel-0.7.3.ebuild
new file mode 100644
index 000000000000..e76bba5ba9fa
--- /dev/null
+++ b/dev-ruby/pastel/pastel-0.7.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Terminal strings styling with intuitive and clean API"
+HOMEPAGE="https://github.com/piotrmurach/pastel"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/equatable-0.6:0
+ >=dev-ruby/tty-color-0.5:0
+"
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+}