summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--profiles/package.mask1
-rw-r--r--sci-geosciences/geocode-glib/files/3.26.4-r200-do-not-install-icons.patch27
-rw-r--r--sci-geosciences/geocode-glib/geocode-glib-3.26.4-r200.ebuild48
3 files changed, 76 insertions, 0 deletions
diff --git a/profiles/package.mask b/profiles/package.mask
index 5273fe3935d3..c6e9d675e9b2 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -559,6 +559,7 @@ sys-devel/automake:1.11
>=gnome-extra/gnome-calculator-43
net-libs/libsoup:3.0
net-libs/webkit-gtk:4.1
+sci-geosciences/geocode-glib:2
# Thomas Deutschmann <whissi@gentoo.org> (2021-09-07)
# Masked while being tested and reverse deps aren't fully compatible
diff --git a/sci-geosciences/geocode-glib/files/3.26.4-r200-do-not-install-icons.patch b/sci-geosciences/geocode-glib/files/3.26.4-r200-do-not-install-icons.patch
new file mode 100644
index 000000000000..c85e250e5c2f
--- /dev/null
+++ b/sci-geosciences/geocode-glib/files/3.26.4-r200-do-not-install-icons.patch
@@ -0,0 +1,27 @@
+geocode-glib-3.26.4 in SLOT="2" has file collissions with geocode-glib-3.26.4 with SLOT="0".
+These file collissions are only 11 svg-files. We do not install them with SLOT="2" and instead only install them with SLOT="0" and
+SLOT="2" depends on SLOT="0" to make sure users that try to only install SLOT="2" get the files regardless.
+
+2022-09-24 - Pascal Jaeger (Schievel) <pascal.jaeger@leimstift.de>
+
+---
+
+diff --git a/icons/meson.build b/icons/meson.build
+index 8d58886..edecbed 100644
+--- a/icons/meson.build
++++ b/icons/meson.build
+@@ -10,14 +10,3 @@ public_icons = [ 'poi-airport.svg',
+ 'poi-restaurant.svg',
+ 'poi-bar.svg',
+ 'poi-light-rail-station.svg' ]
+-
+-foreach icon : public_icons
+- file = join_paths('maki' , icon)
+- install_dir = join_paths(get_option('datadir'),
+- 'icons',
+- 'hicolor',
+- 'scalable',
+- 'places')
+-
+- install_data(file, install_dir: install_dir)
+-endforeach
diff --git a/sci-geosciences/geocode-glib/geocode-glib-3.26.4-r200.ebuild b/sci-geosciences/geocode-glib/geocode-glib-3.26.4-r200.ebuild
new file mode 100644
index 000000000000..2912deb19a51
--- /dev/null
+++ b/sci-geosciences/geocode-glib/geocode-glib-3.26.4-r200.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org meson xdg
+
+DESCRIPTION="GLib helper library for geocoding services"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/geocode-glib"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="gtk-doc +introspection test"
+RESTRICT="!test? ( test )"
+
+# Needs to depend on geocode-glib-3.26.4:0 because only slot 0 has some svg
+# files that we patch out here to avoid file collisions.
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/json-glib-0.99.2[introspection?]
+ >=net-libs/libsoup-3.0.8:3.0[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ >=sci-geosciences/geocode-glib-3.26.4:0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.13
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-r200-do-not-install-icons.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Denable-installed-tests=false
+ $(meson_use introspection enable-introspection)
+ $(meson_use gtk-doc enable-gtk-doc)
+ -Dsoup2=false
+ )
+ meson_src_configure
+}