summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/pms/files/pms-0.42_p20170508-gcc12-time.patch11
-rw-r--r--media-sound/pms/pms-0.42_p20170508-r1.ebuild6
2 files changed, 16 insertions, 1 deletions
diff --git a/media-sound/pms/files/pms-0.42_p20170508-gcc12-time.patch b/media-sound/pms/files/pms-0.42_p20170508-gcc12-time.patch
new file mode 100644
index 000000000000..b0d586eff2c3
--- /dev/null
+++ b/media-sound/pms/files/pms-0.42_p20170508-gcc12-time.patch
@@ -0,0 +1,11 @@
+https://bugs.gentoo.org/851621
+--- a/src/message.cpp
++++ b/src/message.cpp
+@@ -23,6 +23,7 @@
+
+
+ #include <cstdarg>
++#include <ctime>
+ #include <stdio.h>
+ #include "message.h"
+
diff --git a/media-sound/pms/pms-0.42_p20170508-r1.ebuild b/media-sound/pms/pms-0.42_p20170508-r1.ebuild
index 9f0546f7b158..750e97d2c674 100644
--- a/media-sound/pms/pms-0.42_p20170508-r1.ebuild
+++ b/media-sound/pms/pms-0.42_p20170508-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,6 +25,10 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.42_p20170508-gcc12-time.patch
+)
+
src_configure() {
local mycmakeargs=(
-DENABLE_DOC=$(usex doc)