summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/umockdev/Manifest1
-rw-r--r--dev-util/umockdev/umockdev-0.11.3.ebuild3
-rw-r--r--dev-util/umockdev/umockdev-0.12.1.ebuild47
3 files changed, 49 insertions, 2 deletions
diff --git a/dev-util/umockdev/Manifest b/dev-util/umockdev/Manifest
index 970f34c6c21c..2ffad98ea21b 100644
--- a/dev-util/umockdev/Manifest
+++ b/dev-util/umockdev/Manifest
@@ -1,2 +1,3 @@
DIST umockdev-0.11.3.tar.xz 753152 BLAKE2B 9f78d160a653ba2c56e97d1b331dfeecd4dd8f6642744849ec3eb85866e4cbce6399679a873b730beddfac2f4bd7572937df4a3db2440ec1bf929849f928bdc6 SHA512 e9086777bb13dbd79b629dc68555d19fb8799720dfc4548926b87d032d94212814cb9e1de10e26f5940a9b5db9a15f62a594f3baf0050ffb9ea30f1563db6d6c
+DIST umockdev-0.12.1.tar.xz 756920 BLAKE2B a8c1d9734f4c0a8e7f19405e011ce964efce6621b4886efead88e040bfe07d2f5a85f063977dfed1c8fb5a5bf4668024b6e687b688a9609cdba1db419518a8ac SHA512 a8995d09179c7d2d37d319f8e675fb15c3caa605c57b56cbb2e785088909d886e790864475feb82ab2b6eb2449038c636a06250d4f9eb8b28b38f0d80574824c
DIST umockdev-0.9.4.tar.xz 754856 BLAKE2B 92182ee856e9432f02cf3a739c7af6f2220394eb4dd81ef6e2949380d124f70d9e34c3d3e49053af43794dd0f2ce0feed8be7366df2c9a06bebee9c52d24ba53 SHA512 c291d3f40a0ab366f14021aa0960852de049f4299a0207d93cec28d5961f3bc7f89448add6f7b35c1262d805d1d638837d4d5e6b734879ffb5910da50019e1cd
diff --git a/dev-util/umockdev/umockdev-0.11.3.ebuild b/dev-util/umockdev/umockdev-0.11.3.ebuild
index f92f538192f4..6d3b197721a2 100644
--- a/dev-util/umockdev/umockdev-0.11.3.ebuild
+++ b/dev-util/umockdev/umockdev-0.11.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,7 +16,6 @@ KEYWORDS="~amd64 ~x86"
IUSE="+introspection static-libs test"
RDEPEND="
- virtual/libgudev:=[${MULTILIB_USEDEP}]
virtual/libudev:=[${MULTILIB_USEDEP}]
>=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
"
diff --git a/dev-util/umockdev/umockdev-0.12.1.ebuild b/dev-util/umockdev/umockdev-0.12.1.ebuild
new file mode 100644
index 000000000000..62e7a21851ea
--- /dev/null
+++ b/dev-util/umockdev/umockdev-0.12.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit multilib-minimal python-any-r1
+
+DESCRIPTION="Mock hardware devices for creating unit tests"
+HOMEPAGE="https://github.com/martinpitt/umockdev/"
+SRC_URI="https://github.com/martinpitt/umockdev/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection static-libs test"
+
+RDEPEND="
+ virtual/libudev:=[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.32:= )
+"
+DEPEND="${RDEPEND}
+ test? (
+ ${PYTHON_DEPS}
+ virtual/libgudev:=[${MULTILIB_USEDEP}] )
+ app-arch/xz-utils
+ >=dev-util/gtk-doc-am-1.14
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+# Tests seem to hang forever
+# RESTRICT="test"
+
+multilib_src_configure() {
+ local ECONF_SOURCE="${S}"
+ econf \
+ --disable-gtk-doc \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable static-libs static) \
+ VALAC="$(type -P true)"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+}