summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/Test-Kit/Manifest1
-rw-r--r--dev-perl/Test-Kit/Test-Kit-2.160.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Test-Kit/Manifest b/dev-perl/Test-Kit/Manifest
index 5d7db1d76cf6..573b0660350b 100644
--- a/dev-perl/Test-Kit/Manifest
+++ b/dev-perl/Test-Kit/Manifest
@@ -1 +1,2 @@
DIST Test-Kit-2.15.tar.gz 18087 BLAKE2B d3175b5d9be51feb128ab57321d800caac9ccdba7ad7b5d7457552514143979c936e2cb9f7025ac75d1b01a2f80e34016c1d7fdb3f47d5781b002651e2c2c0d0 SHA512 ef798307e44c214f3b312b1bde3b48a39948c72c683a17b0e0ab7b097cbc991408a6382d06a94bbfa8cd0e6d92a4ba5339245463c249660f987dd8a5aef4691e
+DIST Test-Kit-2.16.tar.gz 18744 BLAKE2B 1c5847e3ba9dc7a01762787df307b1961acec69fc9fbab881424da9a00e84c0082753070a88c615a105d93cbe5021475dd71c76ad4c46a0163d64a4f8cdfc0d1 SHA512 077fa559cd1582c9ef30427ddba0bd77a8dde0d9e979dfc92e7f35781363e701f14c90e31a85df8e7c924ab7f9af4125bffe892b10b56cc2f6ef1d3a3b590364
diff --git a/dev-perl/Test-Kit/Test-Kit-2.160.0.ebuild b/dev-perl/Test-Kit/Test-Kit-2.160.0.ebuild
new file mode 100644
index 000000000000..251c0fe003c9
--- /dev/null
+++ b/dev-perl/Test-Kit/Test-Kit-2.160.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=KAORU
+DIST_VERSION=2.16
+inherit perl-module
+
+DESCRIPTION="Build custom test packages with only the features you want"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86 ~x64-macos"
+
+RDEPEND="
+ virtual/perl-Exporter
+ dev-perl/Hook-LexWrap
+ dev-perl/Import-Into
+ dev-perl/Module-Runtime
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Sub-Delete
+ virtual/perl-Test-Simple
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Exception
+ dev-perl/Test-NoWarnings
+ dev-perl/Test-Output
+ >=virtual/perl-Test-Simple-0.920.0
+ dev-perl/Test-Warn
+ )
+"
+PERL_RM_FILES=(
+ "t/author-pod-syntax.t"
+ "t/release-cpan-changes.t"
+)