summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild b/dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild
new file mode 100644
index 000000000000..f3f5e5f2fdee
--- /dev/null
+++ b/dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Universal Binary JSON encoder/decoder"
+HOMEPAGE="
+ https://github.com/Iotic-Labs/py-ubjson/
+ https://pypi.org/project/py-ubjson/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest -s test
+}