summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/stestr/stestr-4.1.0.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-python/stestr/stestr-4.1.0.ebuild b/dev-python/stestr/stestr-4.1.0.ebuild
index ae45f1d2241a..facea035e081 100644
--- a/dev-python/stestr/stestr-4.1.0.ebuild
+++ b/dev-python/stestr/stestr-4.1.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
@@ -39,6 +39,7 @@ BDEPEND="
"
python_test() {
+ local -x PYTHONPATH="${BUILD_DIR}/install$(python_get_sitedir)"
stestr init || die
stestr run || die "Tests failed with ${EPYTHON}"
}