summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/clang-common/clang-common-15.0.0.9999.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/sys-devel/clang-common/clang-common-15.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-15.0.0.9999.ebuild
index 71768ae561e5..46b53588191e 100644
--- a/sys-devel/clang-common/clang-common-15.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-15.0.0.9999.ebuild
@@ -1,23 +1,24 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit bash-completion-r1 llvm.org
DESCRIPTION="Common files shared between multiple slots of clang"
HOMEPAGE="https://llvm.org/"
+S=${WORKDIR}/clang/utils
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
KEYWORDS=""
-IUSE=""
-PDEPEND="sys-devel/clang:*"
+PDEPEND="
+ sys-devel/clang:*
+"
LLVM_COMPONENTS=( clang/utils/bash-autocomplete.sh )
llvm.org_set_globals
-S=${WORKDIR}/clang/utils
src_install() {
newbashcomp bash-autocomplete.sh clang