summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/lvm2/lvm2-2.03.22-r1.ebuild22
-rw-r--r--sys-fs/lvm2/lvm2-2.03.22-r2.ebuild22
2 files changed, 22 insertions, 22 deletions
diff --git a/sys-fs/lvm2/lvm2-2.03.22-r1.ebuild b/sys-fs/lvm2/lvm2-2.03.22-r1.ebuild
index 263e01250962..6d98d1035b43 100644
--- a/sys-fs/lvm2/lvm2-2.03.22-r1.ebuild
+++ b/sys-fs/lvm2/lvm2-2.03.22-r1.ebuild
@@ -194,17 +194,17 @@ src_test() {
}
src_install() {
- local INSTALL_TARGETS=(
- # full LVM2
- $(usev lvm "install install_tmpfiles_configuration")
- # install systemd related files only when requested, bug #522430
- $(usev $(usex lvm systemd lvm) "SYSTEMD_GENERATOR_DIR=$(systemd_get_systemgeneratordir) \
- install_systemd_units install_systemd_generators")
-
- # install dm unconditionally
- install_device-mapper
- )
- emake V=1 DESTDIR="${D}" "${INSTALL_TARGETS[@]}"
+ local targets=()
+ if use lvm; then
+ targets+=( install install_tmpfiles_configuration )
+ if use systemd; then
+ # install systemd related files only when requested, bug #522430
+ targets+=( install_systemd_units )
+ fi
+ else
+ targets+=( install_device-mapper )
+ fi
+ emake V=1 DESTDIR="${D}" "${targets[@]}"
newinitd "${FILESDIR}"/device-mapper.rc-r3 device-mapper
newconfd "${FILESDIR}"/device-mapper.conf-r4 device-mapper
diff --git a/sys-fs/lvm2/lvm2-2.03.22-r2.ebuild b/sys-fs/lvm2/lvm2-2.03.22-r2.ebuild
index cac7188abf10..ba546b95e777 100644
--- a/sys-fs/lvm2/lvm2-2.03.22-r2.ebuild
+++ b/sys-fs/lvm2/lvm2-2.03.22-r2.ebuild
@@ -194,17 +194,17 @@ src_test() {
}
src_install() {
- local INSTALL_TARGETS=(
- # full LVM2
- $(usev lvm "install install_tmpfiles_configuration")
- # install systemd related files only when requested, bug #522430
- $(usev $(usex lvm systemd lvm) "SYSTEMD_GENERATOR_DIR=$(systemd_get_systemgeneratordir) \
- install_systemd_units install_systemd_generators")
-
- # install dm unconditionally
- install_device-mapper
- )
- emake V=1 DESTDIR="${D}" "${INSTALL_TARGETS[@]}"
+ local targets=()
+ if use lvm; then
+ targets+=( install install_tmpfiles_configuration )
+ if use systemd; then
+ # install systemd related files only when requested, bug #522430
+ targets+=( install_systemd_units )
+ fi
+ else
+ targets+=( install_device-mapper )
+ fi
+ emake V=1 DESTDIR="${D}" "${targets[@]}"
newinitd "${FILESDIR}"/device-mapper.rc-r3 device-mapper
newconfd "${FILESDIR}"/device-mapper.conf-r4 device-mapper