summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.127.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index 19d837c08243..a6f7d77dbb15 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -6,3 +6,4 @@ DIST zeroconf-0.122.3.tar.gz 158519 BLAKE2B f62d36234c4f1cd988bbf8b1d1e6f706498b
DIST zeroconf-0.123.0.tar.gz 158902 BLAKE2B d940e9558e781d614d623701e8baf3c9a2feb292bcb0ad8241fc28e1bdf103a154cf178b37dfc9f9ae1805ee6e6d1601cd41574755fe9849243832c3bd57821e SHA512 65947861a76776a1e34807ca5b0570f93c026b8fa36456ae6bfdec747c484107ba2c2e12712ce1a81a05c6c817215f7f72aa40a48e6634f1b1be886349f8c73f
DIST zeroconf-0.125.0.tar.gz 160220 BLAKE2B aa84106acc07d19766a1ecdb4db36367ff9d80b1f88b81c665499c59dfc95cdb3123d5252f53fb488d4f632afdff862cf138a763106da652facb4e43bc404b8b SHA512 ba24b9dbcf91090404906df0127b0ba94fe3af65aae86788ff703b14b8f4dcffe9e08bc6be3b122a16036bc87df6307066ad291f74b02846a5b79279e24c150b
DIST zeroconf-0.126.0.tar.gz 160628 BLAKE2B 09ff7d4ccde02d258b26f0a1e72ac7fbaf61a4a6513fa7c216e0015afa07107f52469a403cf8866aa38a55b7e96dbf1ef6cecd698e3b5b8902030e02cb7aa600 SHA512 7ceaeb39e292426fcfafd62d3a34bea40ba1ff2570489d6b9de2c3be9d8e27cbbbad90fbe6de45f0be1a0d769b0756c299a2c7358bb3689c163bca1373656bc5
+DIST zeroconf-0.127.0.tar.gz 161143 BLAKE2B ee560845016ab1de0b065aaae8cd6791ddc847417241c7f2477301948945e938a2ff68206d30166a6049a7ad5919d15bcc6acac9fd9d33d17d5e77154b9f9c0c SHA512 7c8aef766dcc0f3411c4230decd5a0af18ae795e0e4253be2dc69af6ba314271a336807ace1458bb0a081455afa8cc9d8769413bbc97f024e3d3e877cd1e6f2f
diff --git a/dev-python/zeroconf/zeroconf-0.127.0.ebuild b/dev-python/zeroconf/zeroconf-0.127.0.ebuild
new file mode 100644
index 000000000000..b3ff07347a6d
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.127.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/python-zeroconf/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-3.0.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+# the build system uses custom build script that uses distutils to build
+# C extensions, sigh
+BDEPEND="
+ >=dev-python/cython-3[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-65.6.3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export REQUIRE_CYTHON=1
+
+python_test() {
+ local -x SKIP_IPV6=1
+ local EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+
+ # fragile to timeouts (?)
+ tests/services/test_browser.py::test_service_browser_expire_callbacks
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+ )
+
+ epytest -o addopts=
+}