summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/sass-listen/files/listen-3.1.5-ruby26.patch33
-rw-r--r--dev-ruby/sass-listen/sass-listen-4.0.0.ebuild6
2 files changed, 37 insertions, 2 deletions
diff --git a/dev-ruby/sass-listen/files/listen-3.1.5-ruby26.patch b/dev-ruby/sass-listen/files/listen-3.1.5-ruby26.patch
new file mode 100644
index 000000000000..f90ab1ed213c
--- /dev/null
+++ b/dev-ruby/sass-listen/files/listen-3.1.5-ruby26.patch
@@ -0,0 +1,33 @@
+From 2908365366792ac3ba010fa32bc3be2beaed451a Mon Sep 17 00:00:00 2001
+From: Samuel Williams <samuel.williams@oriontransfer.co.nz>
+Date: Sun, 16 Dec 2018 11:32:45 +1300
+Subject: [PATCH] Use raw Pathname to fix Linux specs.
+
+---
+ lib/listen/adapter/linux.rb | 2 +-
+ spec/lib/listen/adapter/linux_spec.rb | 12 +-----------
+ 2 files changed, 2 insertions(+), 12 deletions(-)
+
+diff --git a/spec/lib/listen/adapter/linux_spec.rb b/spec/lib/listen/adapter/linux_spec.rb
+index d77f0c0..da48319 100644
+--- a/spec/lib/listen/adapter/linux_spec.rb
++++ b/spec/lib/listen/adapter/linux_spec.rb
+@@ -10,17 +10,7 @@
+ end
+
+ if linux?
+- let(:dir1) do
+- instance_double(
+- Pathname,
+- 'dir1',
+- to_s: '/foo/dir1',
+- cleanpath: real_dir1
+- )
+- end
+-
+- # just so cleanpath works in above double
+- let(:real_dir1) { instance_double(Pathname, 'dir1', to_s: '/foo/dir1') }
++ let(:dir1) {Pathname.new("/foo/dir1")}
+
+ let(:config) { instance_double(Listen::Adapter::Config) }
+ let(:queue) { instance_double(Queue) }
diff --git a/dev-ruby/sass-listen/sass-listen-4.0.0.ebuild b/dev-ruby/sass-listen/sass-listen-4.0.0.ebuild
index 7d102181faca..3e6486958d11 100644
--- a/dev-ruby/sass-listen/sass-listen-4.0.0.ebuild
+++ b/dev-ruby/sass-listen/sass-listen-4.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25"
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
@@ -24,6 +24,8 @@ SLOT="4"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
IUSE="test"
+PATCHES=( "${FILESDIR}/listen-3.1.5-ruby26.patch" )
+
ruby_add_rdepend ">=dev-ruby/rb-inotify-0.9.7"
ruby_add_bdepend "test? ( dev-ruby/thor )"