summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/tarsnap/tarsnap-1.0.35.ebuild')
-rw-r--r--app-backup/tarsnap/tarsnap-1.0.35.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-backup/tarsnap/tarsnap-1.0.35.ebuild b/app-backup/tarsnap/tarsnap-1.0.35.ebuild
new file mode 100644
index 000000000000..375c60a3cbb0
--- /dev/null
+++ b/app-backup/tarsnap/tarsnap-1.0.35.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Online backups for the truly paranoid"
+HOMEPAGE="http://www.tarsnap.com/"
+SRC_URI="https://www.tarsnap.com/download/${PN}-autoconf-${PV}.tgz"
+
+LICENSE="tarsnap"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="acl bzip2 lzma cpu_flags_x86_sse2 xattr"
+
+RDEPEND="dev-libs/openssl:0
+ sys-libs/e2fsprogs-libs
+ sys-libs/zlib
+ acl? ( sys-apps/acl )
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ xattr? ( sys-apps/attr )"
+DEPEND="${RDEPEND}
+ virtual/os-headers" # Required for "magic.h"
+
+S=${WORKDIR}/${PN}-autoconf-${PV}
+
+src_configure() {
+ econf \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable xattr) \
+ $(use_enable acl) \
+ $(use_with bzip2 bz2lib) \
+ --without-lzmadec \
+ $(use_with lzma)
+}