summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/podman-compose/Manifest1
-rw-r--r--app-containers/podman-compose/podman-compose-1.3.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-containers/podman-compose/Manifest b/app-containers/podman-compose/Manifest
index 9b60d9686f04..d0382f962bb3 100644
--- a/app-containers/podman-compose/Manifest
+++ b/app-containers/podman-compose/Manifest
@@ -1 +1,2 @@
DIST podman-compose-1.2.0.gh.tar.gz 84708 BLAKE2B ab1f458cef6db99c5727a6676cd1a15ccc58108a14763b9bf8e1093bc674e1adbee21c81744a0cb7798be6134e7b566a4ed9222be71bda0d8f7e4568b3d2fcb7 SHA512 2b45bcb331e334d362a0906563377e1514aca95f50c575e4b53039e58394b39af1ceeb606d90c652ef6d8cc5e8764a27edf11fc9782a89b186812a474b583579
+DIST podman-compose-1.3.0.gh.tar.gz 103006 BLAKE2B aa3202e23728d71cb7685ceeac5ba67d638477666ae5863d67ed36d404a84e897ffbf60c4188aedf5fda06b43db697baff338f43c8637981ffa3c4e62872f140 SHA512 7f7be6d0d230554f766aa9d7d2e4a8b16155780706859f6f0ee94b7e73bd6b095f20948ff168f5492690ee7e8f5acd7dd8d88219d8721c483214eba74575a582
diff --git a/app-containers/podman-compose/podman-compose-1.3.0.ebuild b/app-containers/podman-compose/podman-compose-1.3.0.ebuild
new file mode 100644
index 000000000000..881806f6e2a1
--- /dev/null
+++ b/app-containers/podman-compose/podman-compose-1.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="A script to run docker-compose.yml using Podman"
+HOMEPAGE="https://github.com/containers/podman-compose"
+SRC_URI="https://github.com/containers/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ app-containers/aardvark-dns
+ app-containers/netavark
+ app-containers/podman
+"
+
+RDEPEND="
+ ${DEPEND}
+ dev-python/pyaml[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests/unit
+}