summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/dieharder/dieharder-3.31.1-r2.ebuild')
-rw-r--r--app-crypt/dieharder/dieharder-3.31.1-r2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-crypt/dieharder/dieharder-3.31.1-r2.ebuild b/app-crypt/dieharder/dieharder-3.31.1-r2.ebuild
new file mode 100644
index 000000000000..5a949f9d0350
--- /dev/null
+++ b/app-crypt/dieharder/dieharder-3.31.1-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="An advanced suite for testing the randomness of RNG's"
+HOMEPAGE="http://www.phy.duke.edu/~rgb/General/dieharder.php"
+SRC_URI="http://www.phy.duke.edu/~rgb/General/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+RESTRICT="test"
+
+RDEPEND="sci-libs/gsl"
+DEPEND="${RDEPEND}
+ doc? ( dev-tex/latex2html )"
+
+DOCS=(
+ NOTES
+)
+HTML_DOCS=()
+
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+ "${FILESDIR}/${P}-urandom-64bit.patch"
+)
+
+pkg_setup() {
+ use doc && DOCS+=(
+ ChangeLog
+ manual/dieharder.pdf manual/dieharder.ps
+ )
+ use doc && HTML_DOCS+=(
+ dieharder.html
+ )
+}
+
+src_compile() {
+ emake -j1
+ use doc && emake -C manual
+}
+
+src_test() {
+ "${S}/dieharder/dieharder" -g 501 -a
+}
+
+src_install() {
+ default
+
+ docinto "dieharder"
+ dodoc dieharder/README dieharder/NOTES
+ docinto "libdieharder"
+ dodoc libdieharder/README libdieharder/NOTES
+}