summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/kakoune/kakoune-2016.05.15.ebuild')
-rw-r--r--app-editors/kakoune/kakoune-2016.05.15.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-editors/kakoune/kakoune-2016.05.15.ebuild b/app-editors/kakoune/kakoune-2016.05.15.ebuild
new file mode 100644
index 000000000000..524324d6dd58
--- /dev/null
+++ b/app-editors/kakoune/kakoune-2016.05.15.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs vcs-snapshot
+
+REF="1788126f385c0d656b6addb0731f6205cc4856e5"
+
+DESCRIPTION="Selection-oriented code editor inspired by vim"
+HOMEPAGE="https://github.com/mawww/kakoune"
+SRC_URI="https://github.com/mawww/${PN}/tarball/${REF} -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ sys-libs/ncurses:*[unicode]
+ dev-libs/boost
+"
+DEPEND="
+ app-text/asciidoc
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )
+
+src_configure() {
+ append-cppflags $(pkg-config --cflags ncursesw)
+ export CXX=$(tc-getCXX)
+ export debug=$(usex debug)
+}
+
+src_compile() {
+ emake -C src
+}
+
+src_test() {
+ emake -C src test
+}
+
+src_install() {
+ emake -C src DESTDIR="${D}" PREFIX="/usr" install
+}