summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/nano/nano-9999.ebuild')
-rw-r--r--app-editors/nano/nano-9999.ebuild40
1 files changed, 20 insertions, 20 deletions
diff --git a/app-editors/nano/nano-9999.ebuild b/app-editors/nano/nano-9999.ebuild
index ce5e828a27c7..4463df57a3e0 100644
--- a/app-editors/nano/nano-9999.ebuild
+++ b/app-editors/nano/nano-9999.ebuild
@@ -40,26 +40,26 @@ src_prepare() {
src_configure() {
use static && append-ldflags -static
- local myconf=()
+ local myconf=(
+ --bindir="${EPREFIX}"/bin
+ --htmldir=/trash
+ $(use_enable !minimal color)
+ $(use_enable !minimal multibuffer)
+ $(use_enable !minimal nanorc)
+ --disable-wrapping-as-root
+ $(use_enable magic libmagic)
+ $(use_enable spell speller)
+ $(use_enable justify)
+ $(use_enable debug)
+ $(use_enable nls)
+ $(use_enable unicode utf8)
+ $(use_enable minimal tiny)
+ $(usex ncurses --without-slang $(use_with slang))
+ )
case ${CHOST} in
- *-gnu*|*-uclibc*) myconf+=( "--with-wordbounds" ) ;; #467848
+ *-gnu*|*-uclibc*) myconf+=( "--with-wordbounds" ) ;; #467848
esac
- econf \
- --bindir="${EPREFIX}"/bin \
- --htmldir=/trash \
- $(use_enable !minimal color) \
- $(use_enable !minimal multibuffer) \
- $(use_enable !minimal nanorc) \
- --disable-wrapping-as-root \
- $(use_enable magic libmagic) \
- $(use_enable spell speller) \
- $(use_enable justify) \
- $(use_enable debug) \
- $(use_enable nls) \
- $(use_enable unicode utf8) \
- $(use_enable minimal tiny) \
- $(usex ncurses --without-slang $(use_with slang)) \
- "${myconf[@]}"
+ econf "${myconf[@]}"
}
src_install() {
@@ -75,9 +75,9 @@ src_install() {
# Enable colorization by default.
sed -i \
-e '/^# include /s:# *::' \
- "${ED}"/etc/nanorc || die
+ "${ED%/}"/etc/nanorc || die
fi
dodir /usr/bin
- dosym /bin/nano /usr/bin/nano
+ dosym ../../bin/nano /usr/bin/nano
}