summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/focuswriter/Manifest1
-rw-r--r--app-editors/focuswriter/focuswriter-1.8.8.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-editors/focuswriter/Manifest b/app-editors/focuswriter/Manifest
index 8b98baf38514..ef355c2031ad 100644
--- a/app-editors/focuswriter/Manifest
+++ b/app-editors/focuswriter/Manifest
@@ -1 +1,2 @@
DIST focuswriter-1.7.6-src.tar.bz2 10311965 BLAKE2B a1f1627df988d7660f6b90cf984d725ff2366754f01b0ce78e23756a98c716acafa8b4076f4749f117cba6eaabcb6ec61516c032a7ae770eb1b06466a358595e SHA512 45e0bc9b20c73b260aa42dcc9ee79515d3ad95d4c9586f60ab75fb404f73c7443484f238b3705ba3224b852a0d9b8b8db17d9145aebb77513f8597a01ab01d3b
+DIST focuswriter-1.8.8.tar.bz2 10640138 BLAKE2B 78abf8e67cafd4d46fd4628f229d2030b4840b066e4b3d04768ad7df3d6a99f1c03bc7f0a15daef3e9c807e1da7ef6f309ce65e8128a3b77ac0c9a8ff6f2a695 SHA512 f41cb82f4d7d3e397fcbc7e1010e379cb410ac67dd35f1b38e7ae7ac791670e29fe5cc710627ffe196a02f23edd423b53fafa2ff4697e560f28c7cf6e1aba388
diff --git a/app-editors/focuswriter/focuswriter-1.8.8.ebuild b/app-editors/focuswriter/focuswriter-1.8.8.ebuild
new file mode 100644
index 000000000000..d48e4a770d50
--- /dev/null
+++ b/app-editors/focuswriter/focuswriter-1.8.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Fullscreen and distraction-free word processor"
+HOMEPAGE="https://gottcode.org/focuswriter/
+ https://github.com/gottcode/focuswriter"
+SRC_URI="https://gottcode.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3+ LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ dev-qt/qttools:6[linguist]
+ virtual/pkgconfig
+"
+RDEPEND="
+ app-text/hunspell:=
+ dev-qt/qtbase:6[concurrent,gui,widgets]
+ dev-qt/qtmultimedia:6
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}"