summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/osm')
-rw-r--r--app-emacs/osm/Manifest1
-rw-r--r--app-emacs/osm/files/50osm-gentoo.el2
-rw-r--r--app-emacs/osm/metadata.xml23
-rw-r--r--app-emacs/osm/osm-0.9.ebuild31
4 files changed, 57 insertions, 0 deletions
diff --git a/app-emacs/osm/Manifest b/app-emacs/osm/Manifest
new file mode 100644
index 000000000000..7657e8302fee
--- /dev/null
+++ b/app-emacs/osm/Manifest
@@ -0,0 +1 @@
+DIST osm-0.9.tar.gz 31248 BLAKE2B ac9bc39ad42046bbec408006a375ad5bda2f561ed5fec7c489c5448ec9f4867ee2d3a7aeecfafbcf078cb4f4780c0e43442e7fa7c7fbe03755835bd56b9312e1 SHA512 4fe88be3bf99175cab4f90d516ef99e3ee7e5209d0046675c92f29a4786fccd92470560771fcfd8887e214b776fac9b75cdd8a0334d2de2d6b42d4313cacd4bd
diff --git a/app-emacs/osm/files/50osm-gentoo.el b/app-emacs/osm/files/50osm-gentoo.el
new file mode 100644
index 000000000000..41333f4b1a0c
--- /dev/null
+++ b/app-emacs/osm/files/50osm-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "osm-autoloads" nil t)
diff --git a/app-emacs/osm/metadata.xml b/app-emacs/osm/metadata.xml
new file mode 100644
index 000000000000..69b999da8796
--- /dev/null
+++ b/app-emacs/osm/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Osm.el is a tile-based map viewer, with a responsive movable and zoomable
+ display. The map can be controlled with the keyboard or with the mouse. The
+ viewer fetches the map tiles in parallel from tile servers via the curl
+ program. The package comes with a list of multiple preconfigured tile
+ servers. You can bookmark your favorite locations using regular Emacs
+ bookmarks or create links from Org files to locations. Furthermore the
+ package provides commands to search for locations by name and to open and
+ display GPX tracks.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/minad/osm/issues/</bugs-to>
+ <remote-id type="github">minad/osm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/osm/osm-0.9.ebuild b/app-emacs/osm/osm-0.9.ebuild
new file mode 100644
index 000000000000..a96d34a47bb3
--- /dev/null
+++ b/app-emacs/osm/osm-0.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="OpenStreetMap tile-based viewer for GNU Emacs"
+HOMEPAGE="https://github.com/minad/osm/"
+SRC_URI="https://github.com/minad/osm/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND=">=app-editors/emacs-${NEED_EMACS}:*[jpeg,json,libxml2,png,svg]"
+RDEPEND="
+ ${BDEPEND}
+ net-misc/curl[ssl]
+"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}