summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/crun/Manifest1
-rw-r--r--app-emulation/crun/crun-0.13.ebuild74
-rw-r--r--app-emulation/crun/files/libocispec-deduplicate-json_common-in-makefile-am.patch31
3 files changed, 106 insertions, 0 deletions
diff --git a/app-emulation/crun/Manifest b/app-emulation/crun/Manifest
index 1652b2325615..56e3366c82be 100644
--- a/app-emulation/crun/Manifest
+++ b/app-emulation/crun/Manifest
@@ -1 +1,2 @@
+DIST crun-0.13.tar.gz 1305048 BLAKE2B fbffabf4cfc744522147b47c5e2bf2bc48e074866108ec4ec8ab94e7ebdc39451851696fabde268b5853e1c3fafb0ac93527e08fdb766acebdd7cf952a9e1a9e SHA512 314612eaf3097160e9369b3400ac8a83e173ef1a53295191c925e96212ba00d032883db1e4615b8ba42ddb08f1e31ca5e5088ea583a469835ac3c27087a88d6e
DIST crun-0.10.6.tar.gz 1242736 BLAKE2B 840699c6a07ddaef3f6ab4ce226fa6c4ebf0e32641012b6467a2a622d575a48286555b84140d5a1c947b5ef00a691045b0618533fb246bfb6d605baa262febe4 SHA512 b7db09d0c7d2d6e8b1ea239ead5a2ca2b97f188a74f08f0d5ac787e0a698fddf596e7cfdde482c6bc8790d06a7705613e877344a44691c0be7388e6d046c4b15
diff --git a/app-emulation/crun/crun-0.13.ebuild b/app-emulation/crun/crun-0.13.ebuild
new file mode 100644
index 000000000000..7b7d5fcda025
--- /dev/null
+++ b/app-emulation/crun/crun-0.13.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit autotools python-any-r1
+
+DESCRIPTION="A fast and low-memory footprint OCI Container Runtime fully written in C"
+HOMEPAGE="https://github.com/containers/crun"
+SRC_URI="https://github.com/containers/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="bpf +caps doc seccomp systemd static-libs"
+
+DEPEND="
+ dev-libs/yajl
+ caps? ( sys-libs/libcap )
+ seccomp? ( sys-libs/libseccomp )
+ systemd? ( sys-apps/systemd:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ doc? ( dev-go/go-md2man )
+"
+
+# the crun test suite is comprehensive to the extent that tests will fail
+# within a sandbox environment, due to the nature of the privileges
+# required to create linux "containers".
+RESTRICT="test"
+
+DOCS=README.md
+
+
+PATCHES=(
+ # see https://709982.bugs.gentoo.org/attachment.cgi?id=614208
+ "${FILESDIR}/libocispec-deduplicate-json_common-in-makefile-am.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-criu \
+ $(use_enable bpf) \
+ $(use_enable caps) \
+ $(use_enable seccomp) \
+ $(use_enable systemd) \
+ $(usex static-libs '--enabled-shared --enabled-static' '--enable-shared --disable-static' '' '')
+}
+
+src_compile() {
+ emake -C libocispec
+ emake crun
+ if use doc ; then
+ emake generate-man
+ fi
+}
+
+src_install() {
+ emake "DESTDIR=${D}" install-exec
+ if use doc ; then
+ emake "DESTDIR=${D}" install-man
+ fi
+
+ einstalldocs
+}
diff --git a/app-emulation/crun/files/libocispec-deduplicate-json_common-in-makefile-am.patch b/app-emulation/crun/files/libocispec-deduplicate-json_common-in-makefile-am.patch
new file mode 100644
index 000000000000..7d188abf8df7
--- /dev/null
+++ b/app-emulation/crun/files/libocispec-deduplicate-json_common-in-makefile-am.patch
@@ -0,0 +1,31 @@
+From 9d58891c058efa55c7b95cb90597d4cadc5c66d8 Mon Sep 17 00:00:00 2001
+From: Bruce Guenter <bruce@untroubled.org>
+Date: Mon, 17 Feb 2020 13:54:14 -0600
+Subject: [PATCH] De-duplicate json_common in Makefile.am
+
+The source file src/json_common.c is listed twice in Makefile.am,
+leading libtool to produce an archive with duplicated symbols. This
+change removes the duplicate source.
+
+This was introduced in commit 2e318803a2c49521ea448e3ae010b1564a7e95ed
+
+Signed-off-by: Bruce Guenter <bruce@untroubled.org>
+---
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 65bed45..c7ede83 100644
+--- a/libocispec/Makefile.am
++++ b/libocispec/Makefile.am
+@@ -7,7 +7,7 @@ GITIGNOREFILES = build-aux/ gtk-doc.make config.h.in aclocal.m4
+ noinst_LTLIBRARIES = libocispec.la
+ noinst_LIBRARIES = libocispec.a
+
+-SOURCE_FILES = src/json_common.c \
++SOURCE_FILES = \
+ src/image_spec_schema_config_schema.c \
+ src/image_spec_schema_content_descriptor.c \
+ src/image_spec_schema_defs.c \
+--
+2.24.1