summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/dailystrips/dailystrips-1.0.28-r2.ebuild')
-rw-r--r--app-misc/dailystrips/dailystrips-1.0.28-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/dailystrips/dailystrips-1.0.28-r2.ebuild b/app-misc/dailystrips/dailystrips-1.0.28-r2.ebuild
new file mode 100644
index 000000000000..1cc829268295
--- /dev/null
+++ b/app-misc/dailystrips/dailystrips-1.0.28-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="dailystrips automatically downloads your favorite online comics from the web"
+HOMEPAGE="http://dailystrips.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dailystrips/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc x86"
+IUSE=""
+
+RDEPEND=">=dev-perl/libwww-perl-5.50
+ dev-perl/DateTime
+ dev-perl/TimeDate"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s:/usr/share/dailystrips/strips.def:/etc/strips.def:" \
+ dailystrips \
+ || die "sed dailystrips failed"
+}
+
+src_install() {
+ dobin dailystrips dailystrips-clean dailystrips-update \
+ || die "dobin failed"
+ dodoc BUGS CHANGELOG CONTRIBUTORS README* TODO
+ insinto /etc
+ doins strips.def || die "doins failed"
+}