summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/fslurp/fslurp-0.9.ebuild')
-rw-r--r--app-misc/fslurp/fslurp-0.9.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/fslurp/fslurp-0.9.ebuild b/app-misc/fslurp/fslurp-0.9.ebuild
new file mode 100644
index 000000000000..96a548caf72f
--- /dev/null
+++ b/app-misc/fslurp/fslurp-0.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Read and display data from Fronius IG and IG Plus inverters"
+HOMEPAGE="http://fslurp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ rm fslurp || die
+}
+
+src_compile() {
+ emake -f makefile CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc History README SampleOutput
+}