summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/iguanaIR/files/iguanaIR-0.93-asneeded.patch')
-rw-r--r--app-misc/iguanaIR/files/iguanaIR-0.93-asneeded.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/iguanaIR/files/iguanaIR-0.93-asneeded.patch b/app-misc/iguanaIR/files/iguanaIR-0.93-asneeded.patch
new file mode 100644
index 000000000000..099b1a4ee4f0
--- /dev/null
+++ b/app-misc/iguanaIR/files/iguanaIR-0.93-asneeded.patch
@@ -0,0 +1,29 @@
+--- iguanaIR-0.93.orig/Makefile.in 2009-12-13 15:27:50.942734390 +0100
++++ iguanaIR-0.93/Makefile.in 2009-12-13 15:29:58.580486676 +0100
+@@ -48,14 +48,14 @@
+ igclient igdaemon: libiguanaIR.so
+
+ libiguanaIR.so: iguanaIR.o support.o dataPackets.o pipes.o base.o
+- $(CC) -shared $(CPPFLAGS) $^ -lpopt -lrt -o $@
++ $(CC) -shared $(CPPFLAGS) $^ -o $@ -lpopt -lrt
+
+ igdaemon: daemon.o client-interface.o device-interface.o usbclient.o \
+ list.o compatibility.o
+- $(CC) $(CPPFLAGS) $(CFLAGS) $^ $(LIBS) -lusb -L. -liguanaIR -o $@
++ $(CC) $(CPPFLAGS) $(CFLAGS) $^ -o $@ -L. -liguanaIR -lusb -lpopt
+
+ igclient: client.o list.o
+- $(CC) $(CPPFLAGS) $^ -lpopt -L. -liguanaIR -o $@
++ $(CC) $(CPPFLAGS) $^ -o $@ -L. -liguanaIR -lpopt
+
+ %.o: %.c Makefile iguanaIR.h
+ $(CC) -c $(CPPFLAGS) $(CFLAGS) $< -o $@
+@@ -71,7 +71,7 @@
+ swig $(CPPFLAGS) -python $<
+
+ _iguanaIR.so: iguanaIR_wrap.c
+- $(CC) $(CPPFLAGS) -shared $(CFLAGS) -Wno-strict-aliasing -Wno-unused -Wno-implicit-function-declaration -Wno-long-long @PYTHON_CPPFLAGS@ $^ -L. -liguanaIR -o $@
++ $(CC) $(CPPFLAGS) -shared $(CFLAGS) -Wno-strict-aliasing -Wno-unused -Wno-implicit-function-declaration -Wno-long-long @PYTHON_CPPFLAGS@ $^ -o $@ -L. -liguanaIR
+ endif
+
+ .PHONY: install