summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/realpath/files/realpath-1.15-build.patch')
-rw-r--r--app-misc/realpath/files/realpath-1.15-build.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/realpath/files/realpath-1.15-build.patch b/app-misc/realpath/files/realpath-1.15-build.patch
new file mode 100644
index 000000000000..7b90a0c0c27b
--- /dev/null
+++ b/app-misc/realpath/files/realpath-1.15-build.patch
@@ -0,0 +1,35 @@
+diff --git a/common.mk b/common.mk
+index 18f539c..142f7e6 100644
+--- a/common.mk
++++ b/common.mk
+@@ -34,16 +34,11 @@ webcgidir := $(prefix)/lib/cgi-bin
+ applicationsdir := $(prefix)/share/applications
+
+ PERL := /usr/bin/perl
+-CC := gcc
+-CFLAGS = -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -Werror -g -DVERSION='"$(VERSION)"' -DPACKAGE='"$(PACKAGE)"' -DLOCALEDIR='"$(nlsdir)"'
+-LDFLAGS :=
+-LIBS :=
++CC ?= gcc
++CFLAGS += -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -DVERSION='"$(VERSION)"' -DPACKAGE='"$(PACKAGE)"' -DLOCALEDIR='"$(nlsdir)"'
++LDFLAGS +=
++LIBS +=
+
+-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+- CFLAGS += -O0
+-else
+- CFLAGS += -O2
+-endif
+
+
+ # determine our version number
+@@ -60,9 +55,6 @@ ifndef VERSION
+ unexport CDPATH ENV
+
+ ifdef DESTDIR
+- ifneq ($(DESTDIR),$(abspath $(DESTDIR)))
+- $(error DESTDIR "$(DESTDIR)" is not an absolute path)
+- endif
+ override ddirshort := DESTDIR
+ export ddirshort
+ endif