summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/libreoffice/libreoffice-7.3.1.1.ebuild')
-rw-r--r--app-office/libreoffice/libreoffice-7.3.1.1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/app-office/libreoffice/libreoffice-7.3.1.1.ebuild b/app-office/libreoffice/libreoffice-7.3.1.1.ebuild
index 286d80a181b0..74a8caa49137 100644
--- a/app-office/libreoffice/libreoffice-7.3.1.1.ebuild
+++ b/app-office/libreoffice/libreoffice-7.3.1.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="threads(+),xml"
@@ -21,7 +21,7 @@ BRANDING="${PN}-branding-gentoo-0.8.tar.xz"
# PATCHSET="${P}-patchset-01.tar.xz"
[[ ${MY_PV} == *9999* ]] && inherit git-r3
-inherit autotools bash-completion-r1 check-reqs eapi8-dosym flag-o-matic java-pkg-opt-2 multiprocessing python-single-r1 qmake-utils toolchain-funcs xdg-utils
+inherit autotools bash-completion-r1 check-reqs flag-o-matic java-pkg-opt-2 multiprocessing python-single-r1 qmake-utils toolchain-funcs xdg-utils
DESCRIPTION="A full office productivity suite"
HOMEPAGE="https://www.libreoffice.org"
@@ -642,10 +642,10 @@ EOF
# link python bridge in site-packages, bug 667802
local py pyc loprogdir=/usr/$(get_libdir)/libreoffice/program
for py in uno.py unohelper.py officehelper.py; do
- dosym8 -r ${loprogdir}/${py} $(python_get_sitedir)/${py}
+ dosym -r ${loprogdir}/${py} $(python_get_sitedir)/${py}
while IFS="" read -d $'\0' -r pyc; do
pyc=${pyc//*\/}
- dosym8 -r ${loprogdir}/__pycache__/${pyc} $(python_get_sitedir)/__pycache__/${pyc}
+ dosym -r ${loprogdir}/__pycache__/${pyc} $(python_get_sitedir)/__pycache__/${pyc}
done < <(find "${D}"${lodir}/program -type f -name ${py/.py/*.pyc} -print0)
done
}