summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/ronn')
-rw-r--r--app-text/ronn/Manifest1
-rw-r--r--app-text/ronn/metadata.xml8
-rw-r--r--app-text/ronn/ronn-0.7.3-r2.ebuild46
-rw-r--r--app-text/ronn/ronn-0.7.3-r3.ebuild46
4 files changed, 101 insertions, 0 deletions
diff --git a/app-text/ronn/Manifest b/app-text/ronn/Manifest
new file mode 100644
index 000000000000..ce1a24d48bae
--- /dev/null
+++ b/app-text/ronn/Manifest
@@ -0,0 +1 @@
+DIST ronn-0.7.3.gem 61440 SHA256 82df6fd4a3aa91734866710d2811a6387e50a7513fc528ce6c7d95ee7ad7f41e SHA512 885418c88d5a1073f9457ea11e29d82d3bb40ad12506589ccfab83ad447445e41282c9688aba5646082ae5ecc6a047fa9439ffae14561152fc61a136474f611c WHIRLPOOL 0497ea22ff387f661381a2d0e13cc8d44068e85ec0b90f40cc80f7effa84c3277ee585464547f926aae853c4a88197c1b1b9056edf2da60583c1005bfa942c65
diff --git a/app-text/ronn/metadata.xml b/app-text/ronn/metadata.xml
new file mode 100644
index 000000000000..ae24f128b707
--- /dev/null
+++ b/app-text/ronn/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">rtomayko/ronn</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/ronn/ronn-0.7.3-r2.ebuild b/app-text/ronn/ronn-0.7.3-r2.ebuild
new file mode 100644
index 000000000000..c121215a6e2c
--- /dev/null
+++ b/app-text/ronn/ronn-0.7.3-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="AUTHORS CHANGES README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ronn converts simple, human readable textfiles to roff for terminal display, and also to HTML"
+HOMEPAGE="http://github.com/rtomayko/ronn/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/hpricot-0.8.2
+ >=dev-ruby/mustache-0.7.0
+ >=dev-ruby/rdiscount-1.5.8"
+
+all_ruby_prepare() {
+ # Avoid test failing due to changes in hash handling in ruby 1.8.7:
+ # https://github.com/rtomayko/ronn/issues/56
+ sed -i -e '81 s:^:#:' test/test_ronn.rb || die
+}
+
+each_ruby_prepare() {
+ # Make sure that we always use the right interpreter during tests.
+ sed -i -e "/output/ s:ronn:${RUBY} bin/ronn:" test/test_ronn.rb
+}
+
+all_ruby_compile() {
+ PATH="${S}/bin:${PATH}" rake man || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/ronn.1 man/ronn-format.7
+}
diff --git a/app-text/ronn/ronn-0.7.3-r3.ebuild b/app-text/ronn/ronn-0.7.3-r3.ebuild
new file mode 100644
index 000000000000..38f0316c801d
--- /dev/null
+++ b/app-text/ronn/ronn-0.7.3-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="AUTHORS CHANGES README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ronn converts simple, human readable textfiles to roff for terminal display, and also to HTML"
+HOMEPAGE="http://github.com/rtomayko/ronn/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/hpricot-0.8.2
+ >=dev-ruby/mustache-0.7.0
+ >=dev-ruby/rdiscount-1.5.8"
+
+all_ruby_prepare() {
+ # Avoid test failing due to changes in hash handling in ruby 1.8.7:
+ # https://github.com/rtomayko/ronn/issues/56
+ sed -i -e '81 s:^:#:' test/test_ronn.rb || die
+}
+
+each_ruby_prepare() {
+ # Make sure that we always use the right interpreter during tests.
+ sed -i -e "/output/ s:ronn:${RUBY} bin/ronn:" test/test_ronn.rb
+}
+
+all_ruby_compile() {
+ PATH="${S}/bin:${PATH}" rake man || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/ronn.1 man/ronn-format.7
+}