summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/aeson-pretty/aeson-pretty-0.7.1.ebuild')
-rw-r--r--dev-haskell/aeson-pretty/aeson-pretty-0.7.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/aeson-pretty/aeson-pretty-0.7.1.ebuild b/dev-haskell/aeson-pretty/aeson-pretty-0.7.1.ebuild
new file mode 100644
index 000000000000..ba5cbd14ffea
--- /dev/null
+++ b/dev-haskell/aeson-pretty/aeson-pretty-0.7.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="JSON pretty-printing library and command-line tool"
+HOMEPAGE="http://github.com/informatikr/aeson-pretty"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE="lib-only"
+
+RDEPEND=">=dev-haskell/aeson-0.6:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/unordered-containers-0.1.3.0:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ !lib-only? ( >=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/cmdargs-0.7:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag lib-only lib-only)
+}