summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/json/json-0.7.ebuild')
-rw-r--r--dev-haskell/json/json-0.7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/json/json-0.7.ebuild b/dev-haskell/json/json-0.7.ebuild
new file mode 100644
index 000000000000..bcb9c2d7b5e6
--- /dev/null
+++ b/dev-haskell/json/json-0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Support for serialising Haskell to and from JSON"
+HOMEPAGE="http://hackage.haskell.org/package/json"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~ppc64 x86 ~amd64-linux"
+IUSE="+generic +parsec +pretty"
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ dev-haskell/text:=[profile?]
+ parsec? ( dev-haskell/parsec:=[profile?] )
+ generic? ( >=dev-haskell/syb-0.3.3:=[profile?] )
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2.0"
+
+src_configure() {
+ [[ $(ghc-version) == "6.12.3" ]] && HCFLAGS+=" -O0" #427838
+
+ cabal_src_configure \
+ $(cabal_flag generic) \
+ $(cabal_flag parsec) \
+ $(cabal_flag pretty)
+}