summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/lhs2tex/lhs2tex-1.18.1.ebuild')
-rw-r--r--dev-haskell/lhs2tex/lhs2tex-1.18.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-haskell/lhs2tex/lhs2tex-1.18.1.ebuild b/dev-haskell/lhs2tex/lhs2tex-1.18.1.ebuild
new file mode 100644
index 000000000000..407bb51fa8df
--- /dev/null
+++ b/dev-haskell/lhs2tex/lhs2tex-1.18.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal
+
+DESCRIPTION="Preprocessor for typesetting Haskell sources with LaTeX"
+HOMEPAGE="http://www.andres-loeh.de/lhs2tex/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# dev-texlive/texlive-mathextra contains 'stmaryrd' font used
+# for guide generation
+RDEPEND=">=dev-tex/polytable-0.8.2
+ dev-texlive/texlive-mathextra"
+
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ dev-haskell/mtl
+ dev-haskell/regex-compat
+ >=dev-lang/ghc-6.12.1"