summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/tasty-quickcheck/tasty-quickcheck-0.8.3.2.ebuild')
-rw-r--r--dev-haskell/tasty-quickcheck/tasty-quickcheck-0.8.3.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/tasty-quickcheck/tasty-quickcheck-0.8.3.2.ebuild b/dev-haskell/tasty-quickcheck/tasty-quickcheck-0.8.3.2.ebuild
new file mode 100644
index 000000000000..e258ceaec0d8
--- /dev/null
+++ b/dev-haskell/tasty-quickcheck/tasty-quickcheck-0.8.3.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="QuickCheck support for the Tasty test framework"
+HOMEPAGE="http://documentup.com/feuerbach/tasty"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="old-quickcheck"
+
+RDEPEND="dev-haskell/tagged:=[profile?]
+ >=dev-haskell/tasty-0.10.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ old-quickcheck? ( >=dev-haskell/quickcheck-2.5:2=[profile?] <dev-haskell/quickcheck-2.7:2=[profile?]
+ dev-haskell/random:=[profile?] )
+ !old-quickcheck? ( >=dev-haskell/quickcheck-2.7:2=[profile?] <dev-haskell/quickcheck-3:2=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/pcre-light
+ dev-haskell/tasty-hunit )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag old-quickcheck old-quickcheck)
+}