summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/jsr250/jsr250-1.2.ebuild')
-rw-r--r--dev-java/jsr250/jsr250-1.2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-java/jsr250/jsr250-1.2.ebuild b/dev-java/jsr250/jsr250-1.2.ebuild
new file mode 100644
index 000000000000..6aff1e7d8edf
--- /dev/null
+++ b/dev-java/jsr250/jsr250-1.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+JAVA_PKG_IUSE="doc source"
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="JSR 250 Common Annotations"
+HOMEPAGE="https://jcp.org/en/jsr/detail?id=250"
+SRC_URI="http://central.maven.org/maven2/javax/annotation/javax.annotation-api/${PV}/javax.annotation-api-${PV}-sources.jar"
+
+LICENSE="|| ( CDDL GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"