summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ocaml/ocaml-4.09.0-r3.ebuild')
-rw-r--r--dev-lang/ocaml/ocaml-4.09.0-r3.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-lang/ocaml/ocaml-4.09.0-r3.ebuild b/dev-lang/ocaml/ocaml-4.09.0-r3.ebuild
index 8bf41d439d5a..7d1b5b6f6592 100644
--- a/dev-lang/ocaml/ocaml-4.09.0-r3.ebuild
+++ b/dev-lang/ocaml/ocaml-4.09.0-r3.ebuild
@@ -5,9 +5,10 @@ EAPI=7
inherit flag-o-matic
-HOMEPAGE="https://ocaml.org/"
-SRC_URI="https://github.com/ocaml/ocaml/archive/${PV}.tar.gz -> ${P}.tar.gz"
DESCRIPTION="Programming language supporting functional, imperative & object-oriented styles"
+HOMEPAGE="https://ocaml.org/"
+SRC_URI="https://github.com/ocaml/ocaml/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-patches-1.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0/$(ver_cut 1-2)"
@@ -24,9 +25,7 @@ PDEPEND="emacs? ( app-emacs/ocaml-mode )
QA_FLAGS_IGNORED='usr/lib.*/ocaml/bigarray.cmxs'
PATCHES=(
- "${FILESDIR}"/${PN}-4.09.0-gcc-10.patch
- "${FILESDIR}"/${P}-cflags.patch
- "${FILESDIR}"/${P}-glibc-2.34.patch
+ "${WORKDIR}"/${P}-patches-1/
)
src_prepare() {
@@ -65,7 +64,8 @@ src_configure() {
$(use_enable flambda)
$(use_enable spacetime)
)
- econf ${opt[@]}
+
+ econf "${opt[@]}"
}
src_compile() {