summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/pocl/pocl-0.13.ebuild')
-rw-r--r--dev-lang/pocl/pocl-0.13.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-lang/pocl/pocl-0.13.ebuild b/dev-lang/pocl/pocl-0.13.ebuild
deleted file mode 100644
index 037505c4b8bb..000000000000
--- a/dev-lang/pocl/pocl-0.13.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit autotools
-
-DESCRIPTION="PortableCL: opensource implementation of the OpenCL standard"
-HOMEPAGE="http://portablecl.org/"
-SRC_URI="http://portablecl.org/downloads/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64"
-IUSE=""
-
-RDEPEND="dev-libs/ocl-icd
- >=sys-devel/llvm-3.7[clang]
- sys-apps/hwloc
- >=app-eselect/eselect-opencl-1.1.0-r4"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-pkg_pretend() {
- # Needs an OpenCL 1.2 ICD, mesa and nvidia are invalid
- # Maybe ati works, feel free to add/fix if you can test
- if [[ $(eselect opencl show) == 'ocl-icd' ]]; then
- einfo "Valid OpenCL ICD set"
- else
- eerror "Please use a supported ICD:"
- eerror "eselect opencl set ocl-icd"
- die "OpenCL ICD not set to a supported value"
- fi
-}
-
-src_prepare() {
- eautoreconf
-}