summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/rccl/rccl-6.1.1.ebuild')
-rw-r--r--dev-libs/rccl/rccl-6.1.1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-libs/rccl/rccl-6.1.1.ebuild b/dev-libs/rccl/rccl-6.1.1.ebuild
index 8b583cb22096..a3838aa9d4a2 100644
--- a/dev-libs/rccl/rccl-6.1.1.ebuild
+++ b/dev-libs/rccl/rccl-6.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -32,6 +32,7 @@ RESTRICT="!test? ( test )"
PATCHES=(
"${FILESDIR}/${PN}-6.0.2-fix-version-check.patch"
+ "${FILESDIR}/${PN}-6.1.1-headers-fix.patch"
)
src_prepare() {
@@ -67,5 +68,6 @@ src_configure() {
src_test() {
check_amdgpu
cd "${BUILD_DIR}" || die
- LD_LIBRARY_PATH="${BUILD_DIR}" edob test/rccl-UnitTests
+ # APU (as second device, if any) expectedly breaks tests
+ HIP_VISIBLE_DEVICES=0 LD_LIBRARY_PATH="${BUILD_DIR}" edob test/rccl-UnitTests
}