summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/stb')
-rw-r--r--dev-libs/stb/Manifest1
-rw-r--r--dev-libs/stb/metadata.xml19
-rw-r--r--dev-libs/stb/stb-20180211.ebuild34
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/stb/Manifest b/dev-libs/stb/Manifest
new file mode 100644
index 000000000000..d666f6933701
--- /dev/null
+++ b/dev-libs/stb/Manifest
@@ -0,0 +1 @@
+DIST stb-20180211.tar.gz 1327803 BLAKE2B a910ac78c5e3760a3e4c74e033d15230c39abd89aeb083ba6c7cd23f8339926e8ab82fde1b6f4fe7a1a312023979a74b961abe263c40b18b3bb8239cbdfa204e SHA512 232ef301d4d6c82c7c5f0e4234b9160cc815f3b6bcc35d341cdf8738646f2f0887ee9838680699f4c9f4274b1390036b2c4fb3ebc2d663af8ff888114dc9f04b
diff --git a/dev-libs/stb/metadata.xml b/dev-libs/stb/metadata.xml
new file mode 100644
index 000000000000..c6be08a32616
--- /dev/null
+++ b/dev-libs/stb/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>3dprint@gentoo.org</email>
+ <name>Gentoo 3D Printer Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>mathy@vanvoorden.be</email>
+ <name>Mathy Vanvoorden</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">nothings/stb</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/stb/stb-20180211.ebuild b/dev-libs/stb/stb-20180211.ebuild
new file mode 100644
index 000000000000..6efc838e61bb
--- /dev/null
+++ b/dev-libs/stb/stb-20180211.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# There are no offical releases
+CHECKSUM="e6afb9cbae4064da8c3e69af3ff5c4629579c1d2"
+
+DESCRIPTION="single-file public domain (or MIT licensed) libraries for C/C++"
+HOMEPAGE="https://github.com/nothings/stb"
+SRC_URI="https://github.com/nothings/stb/archive/${CHECKSUM}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( MIT Unlicense )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+S="${WORKDIR}/${PN}-${CHECKSUM}"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ default
+
+ # Move the header files in a folder so they don't pollute the include dir
+ mkdir stb || die
+ mv *.h stb/ || die
+}
+
+src_install() {
+ doheader -r stb
+}